DMDE - О справке

Содержание Online: en pl ru
Версия инструкции от 30.10.2020

Справка DMDE 3.8

Наиболее актуальную документацию можно найти на сайтах программы.

В справке курсивом выделены элементы интерфейса программы, в квадратные скобки заключены коды клавиш и их сочетания, моноширинным зелёным шрифтом - текст для набора и имена файлов.

Ввиду отсутствия картинок чтение руководства рекомендуется при непосредственной работе с программой. Также доступна контекстная справка (за исключением DOS) и вызывается клавишами [F1], [Shift+F1] или [Shift+F11], либо кнопкой Справка. Подсказки (в интерфейсе GUI) включаются и отключаются через меню Справка.

Понимание некоторых настроек программы требует специальных знаний о файловых системах и дисковых структурах. Если роль таких параметров не понятна, рекомендуется оставить значения по умолчанию.

Чтобы открыть в Windows CHM-файлы справки, полученные из Интернета, необходимо скопировать их на локальный диск и разблокировать (клик правой кнопкой - Свойства - Разблокировать).

Справка в виде HTML-файлов поддерживается в Linux, Windows, macOS. CHM-файлы - в Windows.

По умолчанию в дистрибутивах для Windows поставляются CHM-файлы. Для использования HTML-файлов следует заменить CHM-файлы каталогами man* (при этом каталог man_en размещается в рабочей директории программы, остальные man* - в поддиректории locals, извлечь каталоги справки можно из дистрибутива для Linux). HTML файлы открываются обозревателем, используемом в системе по умолчанию.

В Linux / macOS для вызова связанного с HTML-файлами приложения используются команды xdg-open / open. Изменить команду можно с помощью параметра shellopen=.


DMDE - О программе

Содержание

О программе DMDE

http://dmde.com/ http://softdm.com/

DMDE 3.8 (DM Disk Editor and Data Recovery Software)
Авторские права © 2005-2020 Дмитрий Сидоров

Описание DMDE Редакции DMDE Файлы дистрибутива Ограничения

Обновления, скачивание, восстановление

Наиболее актуальные версии доступны на сайтах ПО (выше). Владельцы лицензий могут скачивать лицензионные копии в персональном разделе. Восстановить адрес входа в персональный раздел можно по ссылке: http://dmde.ru/request.html

Благодарности

Спасибо всем пользователям за замечания, предложения, сообщения об ошибках, поддержку, распространение информации.

Особая благодарность пользователям:
Игорь (jsfhd), Alex (irman.at.tut.by), Константин Волков, Леонид Аркадьев, Antech (MediaWorkshop), Yatagan, 9285, Okzo, Nirvanowiec, Migol21, Gsm_virus, Bigolsen, Stepan Martinek, Przemyslaw Iwanowski, H.Mohamadi, Вениамин Хозяинов, Juri Micheli, rk, Rogerio Copetti, Zhou Xiaodong


DMDE - О программе

Содержание · О программе DMDE

Описание DMDE

http://dmde.ru/ http://dmde.com/

Программа для поиска, редактирования и восстановления данных на дисках.

  • Набор бесплатных возможностей, дополнительные платные фнукции (редакции DMDE)
  • Версии для Windows, macOS, Linux, DOS
  • Портативный запуск без необходимости установки
  • Поддержка ФС NTFS, FAT12/16, FAT32, exFAT, ReFS, Ext2/Ext3/Ext4, HFS+/HFSX, APFS
  • Специальные алгоритмы полного сканирования и реконструкции ФС для восстановления данных в сложных случаях
  • Простой менеджер разделов для экспресс-диагностики разделов с возможностью быстрого восстановления случайно удалённых и потерянных разделов
  • Клонирование и создание образов дисков, с управлением на "бэдах", реверсивное копирование и другие возможности
  • Конструктор RAID для сборки виртуальных массивов с поддержкой уровней RAID-0, RAID-1, RAID-4, RAID-5, RAID-6, в т.ч., с задержкой чётности, а также с чередованием, определяемым пользователем, сборка томов JBOD/spanned; автоматический расчет конфигураций RAID
  • Карта кластеров для исследования размещения файлов
  • Дисковый редактор, совместимый с последними версиями Windows – для просмотра, редактирования различных дисковых структурых и переходов между ними с помощью встроенных и пользовательских шаблонов
  • NTFS утилиты для копирования, удаления файлов, создания, исправления, удаления директорий с обход стандартного драйвера NTFS
  • Поддержка различных интерфейсов и параметров ввода-вывода для работы со сбойными дисками, образов дисков, сжатия и шифрования NTFS, национальных имён, больших дисков, больших файлов, больших секторов, трансляции размера сектора, и других специальных возможностей


Редакции DMDE (DMDE Editions)

Актуальная информация - на сайте программы (сравнение редакций, покупка).

Для получения всех возможностей Professional Edition необходимо скачать программу в персональном разделе сайта. В остальных случаях достаточно ввести актуальный лицензионный ключ в базовую версию, чтобы снять лимит восстановления данных. Обновить, изменить, восстановить лицензию можно в персональном разделе сайта (восстановление входа).

Редакция Free Edition содержит все основные функции, но одной командой можно восстановить до 4000 файлов только из текущей панели (следует сначала открыть директорию с требуемыми файлами в панели, a затем выбрать восстановление из панели). Ввод лицензионного ключа снимает ограничение, позволяет восстанавливать вложенные директории в соответствии с построенным в программе деревом директорий.

Лицензия Professional Edition предоставляет дополнительные возможности:

  • право оказывать услуги по восстановлению данных
  • портативный запуск на разных компьютерах
  • одноразовая активация на клиентских компьютерах (в т.ч. удалённое использование)
  • создание отчётов восстановления данных (включая логи и контрольные суммы)
  • использование логов посекторного копирования (возобновление, несколько проходов)
  • поддержка чтения файлов образов дисков в формате E01
  • настраиваемый скрипт обработки ввода-вывода
  • восстановление дополнительных потоков данных NTFS
  • DMA-доступ в DOS (для интерфейса ATA)


DMDE - Описание файлов

Содержание · О программе

Описание файлов программы

Исполняемые файлы

dmde.exe / dmde - программа

Файлы локализаций

*.tbl - таблицы кодовых страниц
*.lng - языковые файлы пользовательского интерфейса

Файлы документации

eula*.txt - файлы лицензионного соглашения (EULA)
versions.txt - информация об изменениях в программе
readme*.txt - файлы Readme
dmde*.chm - файлы справки в формате Windows CHM
man*/* - файлы справки в формате HTML

Другие файлы

dev9x.dll, dev32.dll - драйверы для работы в Windows 98/ME
dmde*.ini - файлы настроек программы
template.txt - шаблоны дискового редактора
cwsdpmi*.exe - DOS Extender для запуска 32-разрядных приложений (Copyright © 2010 CW Sandmann, не является частью программы DMDE)


DMDE - Проблемы и ограничения

Содержание · О программе DMDE

Известные проблемы и ограничения

Восстановление данных

  • Сохранение данных допускается только на разделы, поддерживаемые ОС (в частности, в чистом DOS, Win9x/ME можно восстанавливать данные только на разделы FAT)
  • DOS, Win9x/ME: символы Юникода в именах файлов вне выбранной кодовой страницы заменяются символом подчерка или транслитерируются в соответствии с загруженными таблицами транслитерации
  • DOS, Win9x/ME или FAT: невозможно восстановить файл более 4 ГБ целиком из-за ограничения файловой системы FAT
  • жёсткие ссылки на файл NTFS восстанавливаются как разные файлы
  • альтернативные потоки данных NTFS для директорий можно восстановить только после реконструкции
  • максимальный размер зашифрованного файла NTFS - 4 ГБ
  • права доступа, владельцы NTFS не поддерживаются
  • максимальная поддерживаемая длина имени APFS - 255 символов
  • символические ссылки, специальные атрибуты и другие специфические свойства ФС не поддерживаются
  • Win9x/ME: диски более 128 ГБ обрабатываются неправильно без установки специальных патчей драйверов Windows
  • максимальная длина пути, поддерживаемая программой: 259 символов - для DOS/Win 9x/ME, 4096 - для Windows 2K+, Linux, macOS
  • максимальная вложенность - 1024 директории (устанавливается параметром maxrecoverdepth=)
  • максимальная длина пути, поддерживаемая DOS: 79 или 127 символов для DOS-имён в зависимости от версии DOS
  • при использовании замены имён в DOS (см. Восстановление данных) расширенная обработка имён (например, автоматическое переименование) не поддерживается

Поддержка NTFS в режиме записи

  • журналирование не поддерживается
  • при создании не поддерживается SECURITY INFORMATION (для доступа к файлам и папкам необходимо установить права средствами ОС)
  • OBJECTID не поддерживается
  • дополнительное создание имён в формате DOS не поддерживается
  • сжатые файлы не поддерживаются
  • альтернативные потоки данных не поддерживаются
  • для создания, дописывания файла необходима непрерывная свободная область

Другие

  • корректная работа возможна в пределах доступной памяти RAM. В 32-разрядных версиях доступно до 3 ГБ памяти (до ~10 млн. файлов/потоков и 2 млн. директорий); в DOS может быть доступен ещё меньший объём
  • в DOS нет дополнительной поддержки файлов образов виртуальных дисков
  • альтернативные потоки данных NTFS для файла отображаются только в одном каталоге, даже если файл жестко связан с несколькими каталогами
  • до 2К окон/панелей/объектов в GUI-версии, либо ограничено шириной в консольных
  • до 2K элементов в списке устройств
  • до 16K пользовательских элементов чередования данных при сборке Custom RAID
  • до 2K видимых томов на секцию при Полном сканировании (параметр showvolumesnum=)
  • до 16 млн. фрагментов MFT для NTFS при Полном сканировании (параметр ntfsmaxmftruns=)
  • максимальная глубина поиска в панели поиска - до 1K вложенных директорий
  • ограниченная поддержка ввода с клавиатуры и мыши в Linux ("горячие" клавиши и национальный ввод могут не поддерживаться)


DMDE - Установка и запуск

Содержание

Установка и запуск

Системные требования Активация Настройки Языки Windows Linux MacOS DOS

Внимание! При сомнениях в физической исправности диска (ошибки ввода-вывода, медленная работа, и т.д.) рекомендуется обращение к специалистам - см. раздел Работа с поврежденным диском. Если диск недоступен или имеет неверный размер - также см. системные требования.

Внимание! Ничего не записывайте на исходный диск, где находятся потерянные данные. Запуск системы и программ должен выполняться c другого диска, восстановление данных также должно производиться только на другой диск, иначе данные могут быть полностью уничтожены.

Крайне рекомендовано работать в системе, которая не пытается лишний раз читать и тем более писать на диски. Можно создать загрузочный диск DOS (для клонирования дисков, доступных в режиме IDE), либо использовать "живые" загрузочные диски (LiveCD/USB) на базе Linux или специальных систем типа WinFE на основе Windows, где минимизирован доступ к дискам.

Для работы таких систем рекомендуется выключить опцию "быстрая загрузка" и включить опцию "USB legacy mode" в настройках BIOS/UEFI. Для загрузки также может потребоваться отключение режимов Secure Boot и UEFI (переключение в режим Legacy BIOS).

Для установки/переустановки и запуска программы необходимо извлечь все файлы программы в отдельную папку (можно на сменном носителе) и запустить файл dmde.exe или dmde в зависимости от версии. Для работы с дисками необходимы права администратора/суперпользователя. Если необходимо запустить программу без прав администратора только для работы с образами дисков, добавьте параметр notadmin=1 в файл настроек dmde.ini. Обновления выполняются так же, как и первоначальная установка.

Для удаления программы достаточно удалить извлеченные файлы и папки.

Операционные системы

Windows Vista/7/выше

В случае запроса SmartScreen нажмите "Подробнее" и подтвердите запуск программы.
Для запуска от имени администратора используйте меню правой кнопки (клик по значку программы) или подтвердите повышение прав пользователя.
Внимание! Для работы с дисками более 2 ТБ должны быть установлены последние версии драйверов контроллера.

Windows 2K/XP

Для запуска в Windows 2K/XP войдите в систему под аккаунтом администратора.
Внимание! Для работы с дисками более 128 ГБ необходима версия Windows 2K с установленным пакетом обновления SP4 и включённой поддержкой LBA48 в реестре, либо версия Windows XP с пакетом обновления SP2 (поддержка LBA48 включена).

Windows 98/ME

Внимание! Без специальных патчей Windows 9x/ME неверно работает с дисками более 128 ГБ.
В этом случае перезагрузите компьютер в режиме MS-DOS и используйте версию для DOS для доступа к дискам через BIOS или ATA-интерфейс, либо загрузите другую ОС.

Linux

Для запуска в Linux неоходимо перейти в Root-терминал или запустить терминальный эмулятор (Konsole, Gnome-terminal или др.), перейти в папку программы и ввести ./dmde. Узнайте, как запустить программу от имени суперпользователя в вашей версии Линукс (например, набрать sudo ./dmde в Ubuntu, предварительно перейти в Root с помощью команды su в Debian и т.д.). При необходимости установите для файла dmde разрешение на запуск (команда chmod 755 ./dmde). Для запуска 32-разрядных версий программы в 64-разрядных ОС может понадобиться установка дополнительных библиотек (например, в Ubuntu можно установить необходимый пакет libc6-i386 с помощью команды sudo apt-get install libc6-i386).

MacOS

Так как новейшие версии macOS препятствуют прямому доступу к дискам, менее подходят для работы с проблемными дисками, то по возможности рекомендуется использовать другие ОС. Если нет другого ПК, на компьютере Mac можно попробовать создать и запустить загрузочный USB-диск Ubuntu (Linux) по инструкции.

Если macOS блокирует доступ к диску, может потребоваться отключение таблицы разделов на диске в другой ОС (в DMDE - команды MBR Off / GPT Off в окне Разделы).

Если при работе в macOS блокируется запуск приложения, используйте Ctrl+Click или перейдите в "Системные настройки", выберите "Безопасность и конфиденциальность" и нажмите "Все равно открыть": Safely open apps on your Mac

Также возможен запуска в качестве пользователя root из терминала, в соответствии с инструкциями для Linux.

MacOS помечает приложения, скачанные из Интернета, и при запуске перемещает их в рандомизированную папку. В этом случае программа не может работать портативно и сохраняет настройки и ключи в пользовательском каталоге для приложений по умолчанию. Для возможности портативного запуска необходимо выполнить в терминале команду
xattr -r -d com.apple.quarantine /<путь к приложению>/dmde.app,
либо просто временно переместить каталог, содержащий приложение и файл dmde.ini, на носитель, не поддерживающий расширенные атрибуты macOS (например, на USB-накопитель отформатированный в FAT).

DOS

При проблемах с некоторыми видеокартами следует поменять значение параметра biosoutput=0 в файле dmde.ini на: biosoutput=1

Возможно использование DMDE как на обычном разделе, поддерживаемом DOS, так и на загрузочном диске DOS, что может помочь при проблемах с использованием конкретного диска. Диски SATA должны быть переведены в IDE-совместимый режим в настройках BIOS для непосредственного ATA-доступа. SCSI-, USB- и другие утройства могут быть доступны через специальный драйверы DOS или с использованием функций BIOS, если они поддерживаются.

Некоторые файлы для создания загрузочных дисков DOS доступны на сайте ПО в разделе Дополнительные файлы для загрузки.

Загрузочная дискета

Чтобы создать загрузочную дискету, скачайте и распакуйте образ FDD. Записать образ на дискету можно с помощью функции Копировать секторы - укажите образ в качестве файла-источника и дискету как устройство-место для записи. Различное ПО также позволяет создавать ISO-образы для загрузочных CD на основе образа FDD.

Загрузочный диск DOS

Загрузка с конкретного устройства должна поддерживаться в BIOS (см. загрузочное меню BIOS). Для создания загрузочного USB/HDD необходим свежеотформатировнный основной раздел FAT16/FAT32 на диске. Нестандартные диски или разделы не поддерживаются (диски без MBR, 3 ТБ+, и т.д.).

0. Для наибольшей совместимости сначала опционально обнулите диск, затем инициализируйте как MBR и создайте и отформатируйте основной раздел FAT средствами ОС (Управление дисками Windows).
1. Cкачайте Пакет FreeDOS (раздел сайта "дополнительные файлы для загрузки") и извлеките все файлы непосредственно в корневую директорию раздела FAT.
2. Откройте диск как физическое устройство в DMDE и используйте команду Прописать загрузочные секторы... в меню окна Разделы, чтобы сделать раздел загрузочным (при последующем запросе укажите корневую директорию на данном диске в качестве источника загрузочных секторов). Примените изменения и выйдите из DMDE.
3. Скачайте DMDE для DOS и распакуйте в созданный раздел FAT.
4. Используйте загурзочное меню BIOS / BIOS setup для загрузки с выбранного диска. В современных системах UEFI может понабодиться включить режим "BIOS legacy", отключить опцию "secure boot", переключить USB и другие устройства в режим "legacy" (совместимости).


DMDE - Системные требования

Содержание · Установка и запуск

Системные требования

Windows Linux MacOS DOS

Общие требования

  • Диски: без существенных аппаратных проблем, без проблем "прошивки"
    Внимание! При сомнениях в исправности устройства (диск недоступен, ошибки ввода-вывода, посторонние звуки, медленная работа, был удар и др.) рекомендуется обращение к специалистам - см. раздел Работа с поврежденным диском.
  • В разделе Установка и запуск - рекомендации по выбору системы для работы
  • Процессор: Intel-совместимый (i486 и выше)
  • Для сохранения/использования результатов, отчётов и настроек требуется исправный раздел, поддерживаемый операционной системой (в частности, для работы в DOS/Win9x/ME требуется раздел FAT)

Неверный размер диска

Не следует работать с диском, объем которого определяется неверно. Некоторые проблемы можно решить самостоятельно - см. руководство из внешнего источника.

  • Перемычка ограничения объёма установлена неверно (размер ограничен 32 ГБ)
  • HPA применено некорректно. Размер обычно становится меньше на 1 TБ (типично для некоторых мат. плат GIGABYTE). Программы для восстановления объёма: HDD Capacity Restore Tool (Windows), hdparm (Linux), HDAT2, MHDD, Victoria (DOS)
  • В OS нет поддержки больших дисков - см. ниже
  • Неправильные драйверы для контроллеров SATA/USB (поддержка 3TB+ некорректна). Размер обычно виден меньше на 2.2 ТБ. Следует обновить драйверы
  • USB-бокс / другой адаптер не имеет корректной поддержки 3TB+. Следует заменить адаптер или присоеднить устройство напрямую
  • Нулевой объем: устройство недоступно, следует обратиться к специалистам

Windows 2K+ (2K/XP/Vista/7/выше)

  • Рекомендуется Windows XP с пакетом обновлений SP2 и выше
  • 32-разрядные версии ПО работают как в 32-, так и в 64-разрядных ОС
  • Наличие у пользователя прав администратора
  • Диски: поддерживаемые операционной системой
  • Для дисков более 2 ТБ требуется Windows Vista/7/выше с установленными последними версиями драйверов контроллера
  • Для дисков более 128 ГБ в Windows 2K/XP необходимы пакеты обновлений (Windows 2K SP4 или Windows XP SP2) и включение в реестре Windows 2K поддержки LBA48. Windows 2K/XP не поддерживает диски более 2 ТБ за исключением специально предназначенных USB-боксов

Windows 98/ME

  • Диски: поддерживаемые операционной системой
    Внимание! Windows 9x/ME неверно работает с дисками более 128 ГБ

Linux

  • Операционная система: один из дистрибутивов Linux с библиотекой libc последних версий
  • Библиотеки для запуска 32-разрядных версий в 64-разрядных ОС (например, пакет libc6-i386)
  • Права суперпользователя
  • Диски: поддерживаемые операционной системой
  • Терминал или эмулятор (xterm, Konsole, Gnome-terminal и др.) для консольных версий или библиотека gtk2.0 для GUI версий
  • Поддержка локали utf-8

MacOS

  • Операционная система: macOS 10.10+
  • Права суперпользователя
  • Диски: поддерживаемые операционной системой, см. Установка и запуск

DOS

  • Операционная система: совместимая с MS-DOS 5.0+
  • Диски: поддерживаемые системой BIOS или поддерживаемые DOS (с использованием драйверов ASPI) или поддерживающие ATA-интерфейс (IDE или SATA). Диски SATA необходимо перевести в режим совместимости (IDE-compatible) в настройках BIOS для работы напрямую через ATA-интерфейс
  • DOS Extender (достаточно наличия файла CWSDPMI.EXE © 2000 CW Sandmann в папке программы)
  • Объём свободной обычной памяти не менее 200 КБ, общий - не менее 64 МБ
  • Для расширенной обработки совпадающих имён при восстановлении данных необходим драйвер длинных имён для DOS (например, DOSLFN.COM © haftman software)
  • Для работы с мышью необходим соответствующий драйвер для DOS


DMDE - Активация

Содержание · Установка и запуск Online: en pl ru fr de

Активация

Внимание! Для получения всех возможностей Professional Edition необходимо скачать программу в персональном разделе. В остальных случаях достаточно ввести свой лицензионный ключ по запросу программы. Во избежание блокировки и отзыва лицензии соблюдайте её условия. Получить актуальный ключ, а также информацию о блокировке можно в персональном разделе (восстановление входа).

Лицензионную копию необходимо активировать при первом запуске на новом/изменённом оборудовании или после ввода ключа.

Активация "онлайн"

Выполняется кнопкой Активация "онлайн" (требуется доступ в Интернет, недоступно в DOS). При успешном соединении с сервером код активации сохранится в файле dmde.ini.

Ручная активация

Если активация "онлайн" недоступна, Вы можете вручную получить и ввести код активации.
1. Запустите программу на компьютере, на котором она будет использоваться. Выберите "Ручная активация" и сохраните файл dmdeinst.dat (либо коды Prod.ID и Inst.ID).
2. Откройте сайт активации http://ac.dmde.com/ или http://ac.softdm.com/ с любого компьютера и отправьте файл dmdeinst.dat (либо введите Prod.ID и Inst.ID). Вам будет выдан код активации.
3. Введите полученный код в программе для завершения активации.

Типы активации (Professional Edition)

1. Стационарная активация

Стационарная активация связывает использование ПО с конкретным компьютером: выберите пункт Стационарная активация (клик или [Пробел]) и используйте ручную или "онлайн" активацию.

2. Портативная активация (портативный запуск)

Портативная активация связывает использование ПО с USB-флеш-накопителем и позволяет запускать ПО на разных компьютерах без доступа в интернет. Доступно в Windows (2K и выше), Linux, macOS.

Первоначальная привязка к устройству

1. Выберите пункт Портативная активация.
2. Укажите съёмное устройство для привязки. Устройство должно всегда отдавать один и тот же корректный серийный номер (12 или более цифр и заглавных латинских букв, например, носители Kingston, SanDisk наиболее соответствуют стандарту).
3. Используйте ручную или "онлайн" активацию для завершения привязки (код привязки сохранится в файле dmde.ini).

Дальнейшее использование на различном оборудовании

Подключите съёмное устройство, запустите ПО и, если потребуется, выберите привязанное устройство в списке.

3. Одноразовая активация

Предназначена для разового использования на компьютере клиента, когда портативная активация невозможна (например, удалённый запуск).

Следует скачать обычную версию программы (без возможностей Professional) и ввести специальный лицензионный ключ Client Edition и одноразовый пароль, которые можно получить в персональном разделе (восстановление входа), и далее выполнить обычную ручную или "онлайн" активацию.


DMDE - Настройки программы

Содержание · Установка и запуск

Настройки программы

Настройки программы хранятся в файле dmde.ini в папке программы (возможное исключение в macOS см. в разделе Установка и запуск). В файле содержится описание параметров.

Параметры доступа к диску можно изменять во время работы программы


DMDE - Языки/Локализация

Содержание · Установка и запуск

Языки/Локализация

Окно диалога "Select Language"

Apply Codepages. При включении опции используются кодовые страницы ANSI и OEM, указанные в языковом файле (вместо системных кодовых страниц).

Translit. Принудительная транислитерация интерфейса (в случае проблем с отображением национальных символов).

Кодовые страницы - интерфейс и восстановление данных

Если имеется поддержка ОС, то используются интерфейс и имена файлов в Юникоде. Иначе кодировка ANSI code page используется в OS Windows 98/ME, OEM code page используется в DOS, а символы вне выбранных кодовых страниц транслитерируются или заменяются.

OEM code page также используется при чтении национальных коротких имён (формат 8.3) на томах FAT.

По умолчанию используются кодовые страницы операционной системы (если определяются). Настройки из ini-файла переопределяют кодовые страницы (если указаны). Кодовые страницы из выбранного lng-файла (*.lng) переопределяют предыдущие настройки, если выбрана опция Apply Codepages в окне диалога "Select Language". Строка 107= lng-файла определяет кодировку ANSI, строка 108= - кодировку OEM.

Параметры INI-файла

usecodepage= ANSI code page
oemcodepage= OEM code page
translitenable= (Translit)
viewtranslit= (Translit)


DMDE - Работа с программой

Содержание

Работа с программой

  • Поиск и открытие тома
  • Восстановление данных
  • Управление разделами
  • Полное сканирование
  • Выбор диска
  • Параметры ввода-вывода
  • Образы и клоны дисков
  • Массивы RAID
  • Панель файлов
  • Дисковый редактор
  • Карта кластеров
  • Меню


DMDE - Поиск и открытие тома

Содержание · Работа с программой

Поиск и открытие тома

Для просмотра, редактирования, восстановления файлов и папок необходимо открыть том, на котором они находились. В зависимости от доступности используются следующие способы.

1. Если том полностью доступен под своей буквой (C:, D:, ...), то его можно открыть как Логический диск (Том / DOS Services) в окне Выбора дисков. Данный способ подходит для восстановления удалённых файлов с исправного тома. Если том не удаётся открыть или файлы восстанавливаются неправильно, используйте следующие способы.

2. В окне Выбора дисков выберите Физическое устройство, на котором находится том. Затем в появившемся окне Разделы выделите и откройте том, если он доступен. Если том не доступен или данные восстанавливаются неправильно, используйте следующий способ для наиболее сложных случаев.

3. Выполните Полное сканирование и откройте один из найденных вариантов тома Ознакомьтесь с разделом справки Полное сканирование для наиболее эффективного восстановления в этом случае.

Команда Открыть параметры тома в контекстном меню позволяет вручную изменить некоторые параметры перед открытием тома.

Том также можно открыть в окне редактора при просмотре загрузочного сектора или его копии в режиме Загрузочный сектор.

Работа со специальными хранилищами

Если хранилище является массивом RAID / томом с чередованием, вначале следует собрать массив RAID, а не выбирать одиночное устройство.

Если том содержится внутри образа виртуальной машины / зашифрованного диска или раздела вначале следует смонтировать / расшифровать образ (или для безопасности его копию), используя соответствующее ПО (виртуализации) и далее работать со смонтированным / расшифрованным диском. Однако, "плоские" и VHD/VHDX образы можно также непосредственно открыть в программе с помощью опции Образы дисков в окне Выбора дисков.


DMDE - Восстановление данных

Содержание · Работа · Меню · Сервис

Восстановление данных

Проблемы с носителем Удаленные файлы Ошибки в файлах Зашифрованные файлы Полное сканирование

Внимание! Убедитесь, что устройство исправно (если имеются проблемы с устройством).

Внимание! Ничего не записывайте и не исправляйте на исходном диске. Рекомендуется восстанавливать данные на другое физическое устройство. Восстановление на другой раздел того же диска возможно только в случае, если разделы на диске не пересекаются и диск не имеет физических проблем. Не загружайте систему и не запускайте программу с раздела, на котором находятся данные для восстановления (Установка и запуск).

Внимание! Если файлы восстанавливаются неправильно или имеются другие проблемы, убедитесь, что используются самые новые версии программы из надёжного источника.

Порядок действий

  • Найти и открыть том, содержащий потерянные данные;
  • открыть виртуальную директорию [Все найденные / виртуальная ФС], чтобы получить больше или меньше найденных файлов (см.: Виртуальная реконструкция ФС);
  • Отметить файлы и папки и использовать команду меню Сервис · "Восстановить" для восстановления данных на другой диск.

В редакции Free Edition одной командой можно восстановить до 4000 файлов только из текущей панели (следует сначала открыть директорию с требуемыми файлами в панели, a затем выбрать восстановление из панели).

Если файлы после восстановления не открываются/не проигрываются, следует попробовать другие варианты тома - вернуться к результатам полного сканирования или к окну Разделы и открыть следующий найденный том.

Окно "Восстановить"

Категории файлов

Выбор категорий файлов для восстановления - см. Панель файлов для подробной информации о категориях. Отметки с исключенных файлов будут сняты, если не включена опция "оставлять отметки выбора для исключенных элементов".

Кнопка "Объём"

Позволяет вычислить объём выбранных данных для восстановления. После вычисления объёма индикатор процесса показывает текущий процент от общего объёма.

Кнопка "Список" · Список файлов

Позволяет сохранить в файл список выбранных файлов с их атрибутами.

Кнопка "Список" · Список секторов

Позволяет получить список секторов, занятых выбранными файлами (например, может использоваться другим программным обеспечением для создания частичного клона диска). В список можно вывести границы фрагментов в секторах и байтах, указать пути к файлам.

Опция Диапазоны секторов позволяет вывести только те фрагменты файлов, которые находятся в указанных диапазонах секторов. Например, это позволяет получить список поврежденных файлов, расположенных в сбойных секторах, при восстановлении из файла образа (или с исправного клонированного диска), который сам по себе не сообщает об исходных поврежденных секторах. Если образ / клон создан с помощью функции Копировать секторы с включенным файлом журнала, то можно экспортировать список поврежденных и пропущенных секторов из журнала с помощью команды в меню диалога "Копировать секторы".

В редакции Free Edition применяются ограничения восстановления данных на число файлов и обработку подкаталогов. В качестве альтернативы без ограничений можно использовать отчет карты кластеров, в этом случае списки также будут отсортированы по положению фрагментов на диске.

Опция "Включая альт. потоки NTFS" (только в Professional Edition)

Восстановить альтернативные потоки данных NTFS. Потоки отображаются в панели файлов после реконструкции ФС, имя альт. потока отделяется двоеточием.

Фильтры файлов

Поддерживается фильтрация по имени, размеру, дате модификации, идентификатору файла. Отметки с исключенных файлов будут сняты, если не включена опция "оставлять отметки выбора для исключенных элементов". Если не нужно ограничивать верхнее значение размера/ID файла, следует указать 0 (ноль) в качестве второго значения.

Шаблоны имён разделяются точкой с запятой. Поддерживаются подстановочные знаки "*" (любой набор символов) и "?" (любой символ). Шаблон для исключения можно задать, добавив впереди обратный слэш "\". Шаблоны вначале имеют приоритет. Например, имя abc.tmp подходит под шаблон a*;\*.tmp и не подходит под \*.tmp;a*.

Если включена опция Обработать только директории с файлами, то будут восстановлены только директории, содержащие файлы, соответстующие фильтрам.

Создать отчёт (только в Professional Edition)

Сохранить отчёт восстановления данных - список файлов и директорий, опционально - ошибки ввода-вывода, контрольные суммы CRC-32, MD5, SHA-1, SHA-256. Имя файла отчета и другие параметры запрашиваются непосредственно перед началом восстановления.

Дополнительные возможности

Имена в юникоде

Опция включена или используется по умолчанию, если ОС поддерживает юникод. Без поддержки юникода символы в именах вне выбранной кодовой страницы будут транслитерированы или заменены (см. Локализация). Недоступно в DOS.

Восстановление на диски FAT, опция "Разделить большие файлы"

Тома FAT не поддерживают файлы более 4 ГБ (в некоторых случаях - 2 ГБ). Файлы большего размера могут быть поделены на части по запросу, если ОС верно сообщает об ошибке (что бывает не всегда), либо если отмечена опция Разделить большие файлы (рекомендуется). Части файла можно объединить на другом диске, например, с помощью системной команды: copy /b part1 + part2 + part3 result. DOS без расширений поддерживает только разделы FAT.

Имена файлов в DOS, опция "Заменить имена"

Без специальных драйверов длинные имена файлов не поддерживаются в DOS. Опция Заменить имена позволяет заменить имена при восстановлении. При этом в папке назначения будет создан файл LRENAME.BAT для обратного переименования. Для восстановления исходных имён необходимо загрузить Windows, перейти в папку назначения и запустить файл LRENAME.BAT.

С опцией utf-8 файл LRENAME.BAT будет создан в формате utf-8 с полной поддержкой юникода. Формат utf-8 поддерживается в Windows 7 и выше. Без опции utf-8 символы, не входящие в выбранную кодовую страницу OEM будут транслитерированы или заменены.

Пути длиной более 259 символов (Windows NT и выше)

Опция Поддержка очень длинных путей (или ручное добавление префикса \\?\ при указании папки назначения, например: \\?\D:\) позволяет восстановить пути длиной более 259 символов. Такие длинные пути могут быть не доступны с использованием стандартных средств ОС ("Проводник").

Обработка совпадений имен, ошибок в файлах и других событий

При восстановлении данных возможно дублирование имён, если обнаружены различные версии одного файла/директории (или различные ссылки), если неправильно объединены директории, если ФС назначения не различает некоторые имена (нечувствительна к регистру), если в директории назначения уже были файлы. Необходимо выбрать способ обработки таких ситуаций.

Доступны опции переименовать/автоматически, пропустить/все, слить/все (для директорий). Также запрашивается порог (максимальное число дубликатов одного имени). При достижении порога выводится повторный запрос на выбор действия. Обработка совпадающих имён не работает при использовании замены имён в DOS.

При восстановлении данных могут быть ошибки ввода-вывода и ошибки файловой системе, которые явно приводят к ошибкам в затронутых файлах. Для таких файлов можно также выбрать способ обработки:
Пропустить - пропустить файл с такими ошибками (пропущенные файлы останутся отмеченными),
Игнорировать - продолжить восстановление с ошибками,
Пропустить и скрыть - продолжить восстановление и скрыть файл (в Windows / DOS будет установлен атрибут "скрытый", в Linux / macOS будет установлен нулевой (0) режим разрешений - без доступа).
Переместить в $Bad - переместить файл внутрь директории $Bad, созданной в директории назначения.

Настроить обработку событий можно и в процессе восстановления, и заранее с помощью опции Обработка событий. Также можно изменить путь назначения, разделить файл, если недостаточно свободного места.

Восстановление зашифрованных файлов NTFS

Зашифрованные файлы NTFS восстанавливаются без расшифровки. Зашифрованный файл содержит зашифрованные данные и ключ шифрования, который, в свою очередь, зашифрован ключом сертификата. Чтобы открывать файлы после восстановления, необходимо установить сертификат из исходной ОС или бэкапа на целевую ОС. Обратитесь к справке Microsoft по экспорту и импорту сертификатов.

Для хранения зашифрованных файлов шифрование NTFS (EFS) должно поддерживаться как ОС, так и целевой файловой системой (то есть требуются Windows и NTFS). В программе имеются дополнительные опции восстановления EFS при работе на других платформах.

Восстановить в отдельные потоки: восстановить потоки данных и ключи в отдельные файлы (назначаются расширения *.efs и *.efk). Дальнейшая обработка этих файлов решается пользователем самостоятельно.
Восстановить в бэкап (портативный формат): восстановить данные и ключ в файл бэкапа (.efb). Файлы бэкапа можно затем восстановить в файлы EFS с помощью команды меню Сервис - Восстановить EFS из бэкапа... при запуске на платформе с поддержкой EFS.
Восстановить в зашифрованный файл NTFS: восстановить сразу в зашифрованный файл NTFS (только при работе на платформе с поддержкой EFS).


DMDE - Работа с повреждённым диском

Содержание · Работа · Восстановление данных

Работа с повреждённым диском

При наличии сомнений в физической исправности устройства (ошибки ввода-вывода, задержки, посторонние звуки, либо был удар, падение и т.д.) настоятельно рекомендуется обратиться к специалистам, имеющим специализированное оборудование. Любая дальнейшая работа с диском (в том числе запуск) может усугубить проблему, привести к полной невозможности восстановления данных и выполняется только на свой страх и риск. В любом случае, работа в программе возможна, только если устройство доступно для чтения, а также размер устройства определяется правильно (см. Системные требования).

Программные ошибки

Некоторые ошибки возникают из-за внешних причин - плохих контактов, потери питания и т.д. Если сектор записался не полностью или некорректно, то при попытке его чтения будет выдаваться сообщение об ошибке даже в отсутствие физического повреждения. Устройство будет работать нормально, за исключением ошибок при чтении некоторых секторов. В таком случае можно устранить причину появления ошибок (очистить окислы на контактах платы, заменить шлейфы, обеспечить надежное питание и т.д.) и продолжить работу, если не растет число ошибок и нет других проблем, указывающих на физические проблемы (не было удара, нет задержек в работе, и т.д.) В любом случае рекомендуется сделать копию на исправный диск.

Клонирование устройства

При восстановлении данных возможны многократные попытки обращения к одним и тем же областям диска: программы, как правило, сканируют всё устройство, затем снова читают данные ФС при построении структуры директорий выбранного раздела, потом снова читают данные ФС и файлов при восстановлении выбранных файлов; кроме того, может потребоваться использование разных настроек или программ. При этом каждая попытка ухудшает состояние поврежденного устройства.

В связи с этим рекомендуется скопировать повреждённое устройство на исправный диск, и дальнейшую работу вести с копией.

В DMDE можно использовать инструмент посекторного копирования для создания посекторной копии. Однако, наиболее надёжно и эффективно данную работу могут выполнить профессиональные специалисты на программно-аппаратных комплексах.

Выбор ОС и работа в ней

В обычных условиях операционная система также может вести активную работу с устройством, усугубляя его состояние и мешая работе. Рекомендации по выбору системы описаны в разделе "Установка".

При этом в программе рекомендуется использовать режим доступа IO SCSI (в Windows/Linux, либо ATA Interface в DOS), как более щадящий и быстрый.

Также, чтобы полностью исключить работу ОС с разделами дисками, можно временно "отключить" таблицу разделов. В DMDE для этого можно выполнить команду MBR Off / GPT Off в окне Разделы, применить, перезагрузить ОС или переподключить диск. Позднее при необходимости таблицу можно "включить" обратно (MBR On / GPT On).

Если клонирование невозможно

Иногда устройство находится в состоянии, когда полное клонирование невозможно или займет слишком большое время, а восстановить нужно только некоторые важные файлы. В таком случае можно попробовать восстановление данных без выполнения полного сканирования.

DMDE позволяет открывать тома и находить некоторые файлы без предварительного полного сканирования. Можно попробовать открыть том, если он виден в окне Разделы сразу после выбора устройства. Также можно попробовать открыть том сразу при появлении в результатах полного сканирования, не дожидаясь его завершения. Следует сохранить результаты, чтобы избежать повторного сканирование в случае какого-либо сбоя, после открытия тома восстановить наиболее важные файлы и убедиться, что они открываются / воспроизводятся.


DMDE - Восстановление удаленных данных

Содержание · Работа · Восстановление данных

Восстановление удаленных данных

Восстановление удаленных файлов в целом выполняется так же, как и восстановление любых данных. Однако, возможность восстановления удаленных файлов зависит от файловой системы, типа устройства, операционной системы и ее активности.

Перезаписанные данные не подлежат восстанавливлению

Реально перезаписанные данные не могут быть восстановлены никакими современными средствами. Для современных жестких дисков нет технологий восстановления данных в том числе после однократной перезаписи. Однако, насколько быстро данные будут перезаписаные после удаления, зависит от активности ОС и конкретного случая. На современных ОС удаленные файлы на системном диске могут быть перезаписаны в течение нескольких секунд. Если необходимо предотвратить перезапись случайно удаленных данных, имеет смысл немедленно отключить питание ПК вместо использования штатной процедуры отключения.

Другим препятствием для восстановления удаленных данных (в том числе путем форматирования диска) является технология trim, используемая на дисках SSD, которая помечает удаленные блоки как пустые, поэтому эти блоки не читаются. Теоретически можно считать банки памяти напрямую с помощью специального оборудования, однако, ротация блоков, а также другие преобразования данных на SSD-дисках не позволяют надежно восстановить такие данные (тем не менее некоторые случайные фрагменты данных все еще можно найти).

В любом случае стоит попробовать восстановление данных, так как нельзя точно сказать, успели ли перезаписаться удаленные данные. За восстановлением ценных данных также стоит обратиться к специалистам со специальным оборудованием и знаниями.

Восстановление удаленных данных по файловой системе

В отличие от восстановления по сигнатурам ("Raw"), восстановление по файловой системе позволяет восстановить файлы с их исходными именами и путями, а также с учетом фрагментации (см. Полное сканирование).

Однако, если данные потеряны вследствие именно удаления, то возможность восстановления по ФС значительно зависит от типа ФС. Некоторые файловые системы сразу уничтожают прежние структуры, а другие только отмечают файлы как удаленные, и они остаются доступны до момента перезаписи. Файловые системы также могут иметь журнал, однако, журнал содержит лишь небольшой объем последних операций. Восстановление по сигнатурам остается как крайнее средство.

Файловая система | Доступность по ФС | Особенности при удалении
NTFS | высокая | Размер больших файлов (>2ГБ) может обнуляться драйвером NTFS в Windows
ReFS, APFS | высокая | Стратегия "copy-on-write" оставляет старые структуры на диске, пока они не будут перезаписаны (если нет trim)
FAT, ExFAT | средняя | Известен только адрес первого фрагмента файла, в FAT32 может частично затираться и адрес первого фрагмента, нет журнала
HFS+/X, Ext3/4 | низкая | в ФС Ext могут оставаться имена, но информация о местоположении файла на диске уничтожается

Восстановление после форматирования

При полном форматировании в ОС Windows, начиная с версии Windows Vista, производится перезапись раздела нулями. Возможно восстановление только данных, не попавших под перезапись (например, форматирование было прервано, ранее был другой размер раздела, др.).

Быстрое форматирование обычно приводит лишь к некоторой потере исходной структуры ФС, некоторых файлов. Однако, исходная фрагментация структур ФС, изменение параметров форматирования, наличие мусора и вкраплений других ФС (например, из образов дисков) могут существенно ухудшить результат реконструкции исходной ФС.

При форматировании FAT/exFAT очищаются таблицы кластеров, содержащие информацию для восставновления фрагментированных файлов.

Предыдущие версии файлов и копии

При потере стоит поискать предыдущие версии файлов или временные копии, а также копии на других дисках.

При использовании точек восстановления Windows ОС может сохранять предыдущие версии файлов. Щелкните правой кнопкой мыши файл/каталог и проверьте в свойствах указание на предыдущие версии, доступные для восстановления.


DMDE - Управление разделами

Содержание · Работа · Меню · Диск

Управление разделами

Инструмент для просмотра, поиска разделов и открытия томов диска, а также для базового управления разделами на дисках с разметкой MBR и GPT. Другие стили (например, гибридная, динамическая) не поддерживаются, при этом разделы могут быть показаны как найденные.

Ознакомьтесь с предупреждением по ссылке перед применением изменений.

Поддерживаются операции, которые изменяют только таблицы разделов и загрузочные секторы, не затрагивая содержимое разделов: удаление и восстановление (в таблице) разделов, восстановление загрузочных секторов из их копий и другие простые операции. Все изменения являются виртуальными и записываются на диск после нажатия на кнопку Применить (Apply), с помощью команды локального меню Применить разметку или команды главного меню Применить изменения.

Окно "Разделы"

При включении опции найдено отображаются потерянные и удалённые разделы (выполняется экспресс-поиск). Тщательный поиск выполняется по команде Полное сканирование.

Чтобы не запускался экспресс-поиск разделов по умолчанию, следует отключить опцию Показать разделы при открытии диска или сборке массива.

При открытии тома из результатов Полного сканирования, том добавляется в список найденных разделов диска и может быть вставлен в таблицу разделов, если не поврежден.

Другие опции отображения:

  • таблицы: показать таблицы AMBR и GPT
  • GiB: отображать размеры в двоичных единицах
  • подробно: отображение нескольких строк на раздел в соответствии с источником информации.

(A) - признак активности (загрузочного) раздела (колонка Разделы).

Индикаторы показывают наличие соответствующих структур:

  • T – таблица разделов
  • E – элемент таблицы разделов
  • B – загрузочный сектор тома
  • C – копия загрузочного сектора/таблицы GPT
  • F – основные структуры ФС (например, начальная запись MFT для NTFS);
  • f – MFTMirr для NTFS;
  • x – соответствующая структура отсутствует или повреждена;

Найденные ошибки выделяются красным цветом. В случае некорректной/нестандартной разметки корректное отображение не гарантировано. Некоторые ошибки в разметке можно исправить удалением и обратной вставкой разделов. До DMDE версии 3.8 основные структуры ФС FAT (индикатор F) тестировались только при открытии тома.

Кнопка Меню показывает список операций, доступных для выбранного раздела или всего диска.

Открыть том

Открытие тома для просмотра и восстановления файлов.

Открыть параметры тома

Просмотр и ручное редактирование пераметров тома перед открытием.

Показать буквы томов

Показать буквы разделов, назначенные ОС в данный момент.

Полное сканирование

Запустить Полное сканирование или загрузить его результаты из файла.

Создать образ/клон

Вызвать окно копирования секторов для создания образа или клонирования раздела.

Вставить раздел (Undelete)

Вставить найденный том в таблицу разделов. Лишние, ошибочные разделы могут мешать вставке, поэтому они должны быть предварительно удалены. Полностью неправильную разметку можно сбросить, применив команду Сигнатура загрузочного сектора к первому пункту списка разделов. Добавлять разделы следует последовательно от начала диска к концу.

Удалить раздел

Удалить существующий раздел диска или лишнюю таблицу разметки.

Создать RAW раздел

Создать неотформатированный (RAW) раздел диска в неразмеченной области. При отсутствии ошибок в разметке диска для создания и удаления разделов рекомендуется использовать только штатные средства операционной системы.

Восстановить загрузочный сектор из копии

Заменить повреждённый загрузочный сектор резервной копией.

Активность загрузочного раздела

Сброс или включение признака активности (A) загрузочного раздела.

Сигнатура загрузочного сектора (MBR On/Off)

Сброс или установка сигнатуры загрузочного сектора (0xAA55).

Снять MBR + GPT сигнатуры (GPT Off)

Снять сигнатуры загрузочного сектора (0xAA55) и GPT таблиц (EFI PART).

Выставить MBR + GPT сигнатуры (GPT On)

Выставить сигнатуры загрузочного сектора и GPT. Доступно только на GPT-дисках после снятия.

Прописать загрузочные секторы

Создать Загрузочный диск DOS.

Отменить действие

Отменить предыдущее действие.

Повторить действие

Повторить отменённое действие.

Отменить изменения разметки

Откатить все изменения в разметке.

Отменить все изменения

Отменить все непримененные изменения.

Загрузить из файла

Загрузить разметку либо информацию отката из файла. Подробнее - см. Изменения.

Сохранить текущую разметку в файл

Сохранить резервную копию текущей разметки в файл. Доступно только если диск размечен и нет непримененных изменений.

Применить разметку

Записать на диск изменённую разметку. Подробнее - см. Применение изменений.


DMDE - Полное сканирование

Содержание · Работа · Меню · Сервис

Полное сканирование

Специальный алгоритм поиска позволяет найти и виртуально реконструировать структуру директорий и файлов повреждённой файловой системы либо найти потерянные файлы известных типов по сигнатурам, если невозможно использовать файловую систему.

Если файловая система тома повреждена незначительно, то том может быть открыт до завершения сканирования. При выборе тома можно ориентироваться на индикаторы качества и другие параметры (подробности - ниже).

Перед работой со специальными типами хранилищ (RAID-массивы / тома c чередованием, зашифрованные хранилища, образы дисков) обратитесь к соответствующим инструкциям (в разделе Открыть том), иначе Полное сканирование даст некорректные результаты поиска по ФС, если запускать его просто на отдельных исходных дисках. В случае с обычным разделом рекомендуется открывать физический диск и сканировать на нем всю область, которую мог занимать раздел (включая возможные старые и новые области), вместо попытки работать с поврежденным логическим диском. При необходимости сканирование может выходить за пределы выбранной области.

При сканировании могут быть обнаружены различные варианты одного тома, которые нужны только в наиболее сложных случаях (прерванное преобразование ФС: перемещение / слияние / разделение / изменение размера раздела / кластера, или составной том). В таких случаях одна часть файлов может быть корректно восстанавлена в одном из вариантов тома, а другая часть - в другом, хотя файлы могут быть видны одновременно в обоих вариантах тома. Откройте выбранный вариант как том и восстановите файлы. Если файлы отсутствуют или восстанавливаются некорректно, следует продолжить поиск или попробовать другой вариант.

Открыть том | Открыть том, выделенный в списке.
Сохранить... | Сохранить результаты сканирования файл.
Загрузить... | Загрузить результаты из файла (можно продолжить сканирование после остановки или открыть сохранённые результаты).
Старт/Стоп | Приостановить/продолжить поиск. Если настройки сбора данных и область поиска не изменены, сканирование будет продолжено.
Параметры | Выбор области поиска, ФС, параметров сбора данных и расчёта томов. Непоследовательное сканирование используется при необходимости быстрее найти основные результаты по всему диску, не дожидаясь завершения сканирования. Непоследовательное сканирование проводится выборочно сразу по всему диску с постепенным покрытием всей области сканирования. В первую очередь обнаруживаются тома с большим количеством файлов.
Лог-файл | Опции для автосохранения состояния и результатов поиска в файл
Меню | В том числе, позволяет изменить сортировку томов.

Столбцы % и Соответствия позволяют предварительно оценить качество восстановления данных для найденного варианта тома. Для NTFS, exFAT, HFS рассчитываются процент и количество правильных соответствий между структрами ФС и файлами, найденными по сигнатурам, для остальных ФС рассчитываются соответствия только для структур ФС.

Мин. размер - минимальная оценка объема, занятого файлами тома (учитываются только наилучшие найденные фрагменты ФС).

Колонка Индикаторы показывает отсутствие (или повреждение) ("-") или наличие ("+") соответствующих структур ФС (B/C - бутсектор/копия; для FAT: F - таблица FAT/копия, R - корневая директория).

Raw-поиск файлов по сигнатурам

Сигнатуры файлов используются для поиска потерянных файлов, когда невозможно использовать результаты поиска по ФС (выше). Кроме того, они используются для улучшения и оценки качества результатов NTFS, exFAT, HFS. Если найдены тома файловых систем (выше), то открывать отдельно результаты Raw-поиска обычно не имеет смысла. Результаты Raw доступны внутри директории $Raw в панели файлов после открытия любого тома.

Восстановление Raw возможно только для файлов, которые имеют специальные сигнатуры (например, в целом не работает для простых текстовых файлов). Восстановление по сигнатурам не работает корректно с фрагментированными файлами (правильно восстанавливается только первый фрагмент). При Raw-поиске не восстанавливаются исходные имена файлов и структура директорий, также не всегда правильно определяется исходные размеры файлов, возможно получение лишних результатов, не являющихся файлами нужного типа, если сигнатура не является достаточно уникальной. Если файл определенного типа не имеет ни сигнатуры конца, ни встроенную информацию о размере, то начало следующего файла считается концом предыдущего, поэтому поиск всех присутствующих на диске типов позволяет точнее определить размеры.

Raw: Сигнатуры файлов: выбор типов файлов для поиска, добавление новых сигнатур.

Сигнатуры файлов

Сигнатура файла - фиксированная последовательность байтов в начале файла определённого типа. Например, при открытии любого PDF-файла в шестнадцатеричном редакторе можно увидеть одну и ту же последовательность первых 4 байт:

0000:   25 50 44 46 2D 31 2E 33  0A ...       %PDF-1.3...
В этом случае в DMDE можно задать сигнатуру строкой %PDF (или \x25\x50\x44\x46 с использованием шестнадцатеричных кодов). Для указания произвольного байта используется знак вопроса (?). Код \mXY обозначает фиксированную битовую маску предыдущего байта сигнатуры, где XY - шестнадцатеричное значение маски (например, код \x05\m07 указывает, что маской 7 = 00000111 (bin) фиксированы только три младших бита значения 5 = 00000101 (bin)).

Если позиция сигнатуры в файле не фиксирована, необходимо указать минимальное и максимально возможное смещение от начала файла. Сигнатура должна целиком умещаться в первые 4096 байта.

Добавление новых типов файлов

Помимо уже встроенных типов файлов и соответствующих сигнатур возможно добавление новых типов пользователем (только если данные типы имеют уникальные сигнатуры): Полное сканирование (Параметры) - Raw: Сигнатуры файлов - Добавить.

В несложных случаях можно автоматически определить сигнатуру нового типа на основе файлов-образцов. Для этого следует нажать на кнопку "..." и указать допустимые расширения файлов (через запятую) и место, где расположены исправные файлы требуемого типа. Если восстановление производится с камеры, для получения образцов можно снять на новый носитель различные фото/видео той же камерой в том же формате.

Кнопка Тест позволяет проверить наличие и правильность сигнатуры на конкретном файле.

Опция использовать для расчета ФС включает проверку соответствий между структурами ФС и файлами, наденными по сигнатуре. Кроме того, файлы внутри ФС будут отмечены в Файловой панели как найденные также по сигнатуре (или не найденные).

Могут быть заданы несколько разделённых запятыми Расширений для расчёта FS.
Можно пометить тип как надёжный, если сигнатура содержит по крайней мере 4 различных байта с фиксированным смещением (в ином случае помечать не следует, чтобы из-за ложных срабатываний не были обрезаны другие файлы).
Файл-контейнер может содержать другие типы файлов внутри себя (следует пометить, чтобы файл не был обрезан при обнаружении файлов другого типа).
Сигнатура EOF - необязательная сигнатура конца файла.


DMDE - Выбор диска

Содержание · Работа · Меню · Диск · Выбрать диск / задачу

Выбор диска / задачи

Выбор диска / образа / лог-файла для дальнейшей работы, выбор другой задачи.

Если диск недоступен или имеет неверный размер - см. системные требования.

Для выбора между опциями физ. устройства и логические диски см. раздел Открытие тома.

Кнопка Параметры позволяет выбрать интерфейс и настроить другие параметры ввода-вывода для работы с поврежденным диском.

В Linux можно использовать опцию Образы дисков / логи, чтобы вручную указать пути для некоторых устройств или виртуальных дисков, которые не отображаются в списке, например, /dev/mmcblk0 или /dev/mapper/truecrypt1.

Опция Образы дисков / логи позволяет открывать образы дисков и загружать логи сканирования. Клик или клавиша Enter на верхнем элементе добавляет новый файл для дальнейшей работы. Кроме обычных посекторных образов поддерживаются файлы образов виртуальных дисков VHD / VHDX, VMDK (без поддержки сжатия / шифрования / записи); в редакции Professional - также образы E01 / Smart (со сжатием).

Если требуется открыть файл с нестандартным / отсутсвующим расширением, следует переключить опцию фильтра в окне открытия файла. В macOS дополнительно нужно нажать Детали/Параметры.

Опция Показать разделы включает экспресс-поиск и показ Разделов сразу после открытия диска.

Другие задачи

С помощью опции Образы дисков / логи можно также загрузить конфигурацию или лог расчета массива RAID или лог Полного сканирования.

Опции собрать RAID и Копировать секторы выполняют переход к соответствующим задачам.


DMDE - Параметры ввода-вывода

Содержание · Меню · Диск

Параметры ввода-вывода

Диалог ввода-вывода Скрипт обработки ввода-вывода

Интерфейс

Способ доступа к секторам диска / тома (задается при выборе диска).

RW Access: открыть устройство с разрешением на запись (зависит от ОС).

Разрешить запись: разрешить запись на диск (Общий режим "только чтение" должен быть выключен).

IO FILE: использовать стандартные функции ОС для доступа к диску (наиболее совместимый режим, но может быть не оптимальным для проблемных дисков, не поддерживается в DOS).

ОС Windows

IO SCSI | использовать драйвер SCSI (более низкий уровень, рекомендуется для уменьшения числа попыток доступа ОС, обхода блокировки записи)
IO ATA | использовать драйвер ATA (может быть плохо реализован в ОС)
Overlapped | использовать режим Overlapped (вероятно, фиктивный для устройств, не рекомендуется)

DOS

  • ATA Interface (прямой доступ, рекомендуется для дисков с "бэдами", см. системные требования)
    ATA Interface | для HDD/SSD
    ATAPI Interface | для CD/DVD
    use DMA | более быстрый доступ DMA для ATA (только в Professional Edition)
    use LBA48 | для доступа к адресам выше 128 ГиБ
    raw CD access | для доступа к нецифровым CD
  • BIOS Services (функции BIOS для работы с дисками)
    Old BIOS Service | старый CHS-доступ до 8.4 ГБ
    Ext BIOS Service | LBA-доступ
  • DOS Services (функции DOS для работы с логическими дисками)
    DOS Int 25/26 | функции DOS
    Win9x-FAT32 Calls | новые функции DOS
    MSCDEX Services | для CD/DVD
  • DOS ASPI (доступ к SCSI-, USB- и другим устройствам при наличии драйверов ASPI)

Ошибки ввода-вывода

Способ обработки ошибок ввода-вывода.

Пропускать ошибки ввода-вывода: при возникновении ошибки продолжить операцию после указанного числа дополнительных попыток (число автоповторов). При отключении опции ожидается выбор пользователя в Диалоге ввода-вывода.

Не ждать, если устройство не готово: продолжить операцию и в случае ошибки, связанной с неготовностью устройства (не рекомендуется).

всегда: применить выбор также к последующим операциям.
сейчас: применить только к текущей операции.

Число автоповторов при ошибке CRC: Число дополнительных попыток доступа при ошибке ввода-вывода. Для исключения дополнительных попыток и задержек ОС Windows не следует использовать интерфейс IO FILE.

Если выбрано нулевое (0) значение числа повторов, то дополнительные попытки доступа не производятся, при этом в буфер ввода-вывода не считываются оставшиеся секторы блока, следующие за ошибкой, или даже более того, содержимое всего буфера ввода-вывода может быть неопределенным при ошибке для некоторых устройств/драйверов.

Если указано ненулевое значение, то производится повторное посекторное считывание блока до сектора с ошибкой включительно. Доступ к сектору с ошибкой производится до успешного считывания или до достижения указанного числа повторов.

Увеличение числа повторов увеличивает процент успешно считанных данных, но уменьшает оставшийся ресурс диска, увеличивая нагрузку.

Число автоповторов, если сектор не найден: дополнительные попытки при других типах ошибок.

Если в результате чтения содержимое буфера не изменилось (или оказалось заполнено нулями), то предполгается, что сектор не найден.

Шаблон для представления плохих секторов (hex): 4-x байтное (hex) значение для заполнения буфера данных при чтении сбойных секторов (при ошибках ввода-вывода).

Прыжок через секторы после ошибки: пропустить указанное число секторов при неустранимой ошибке чтения.

Если повреждённые секторы на диске располагаются группами, то перескок позволяет существенно снизить нагрузку и дальнейшее повреждение диска, однако, уменьшает качество восстановления в случае одиночных нечитаемых секторов.

Прочитать назад после прыжка: прочитать секторы после прыжка обратным ходом до повторной ошибки.

Опция недоступна, если выбрана большая величина перескока. Обратное чтение позволяет повысить качество восстановления при некотором увеличении нагрузки на диск.

Шаблон для представления пропущенных секторов (hex): 4-x байтное (hex) значение для заполнения буфера данных для пропущенных секторов.

Дополнительные параметры

Размер буфера ввода-вывода (в секторах): Максимальное число секторов, передаваемых при операции ввода-вывода.

Тайм-аут, мс: Время ожидания ответа в миллисекундах (в DOS для ATA Interface).

SCSI/ATA тайм-аут, с: Тайм-аут для интерфейсов IO SCSI/ATA (в Windows, может игнорироваться ОС).

При ошибке повторно открыть дескриптор диска: проверить, что устройство используется ОС после ошибки, для предотвращения фиктивного доступа (Windows и Linux).

Повторить ввод-вывод при подключении устройства: автоматическое возобновление операции при повторном подключении устройства (только для Windows GUI).

ATA soft reset, если занято: выполнить программный сброс ATA soft reset, если устройство не готов по истечении тайм-аута (только для ATA Interface в DOS).

ATA soft reset timeout, ms.: время ожидания готовности после программного сброса.

Скрипт..: настройка пользовательского скрипта обработки ввода-вывода.

SMART: показать отчёт SMART.


DMDE - Диалог ввода-вывода

Содержание · Работа ·

Диалог ввода-вывода

Параметры ввода-вывода Скрипт обработки ввода-вывода

При возникновении ошибок чтения или записи выводится окно, позволяющее выбрать способ обработки ошибок ввода-вывода. Внимание! Ознакомьтесь с информацией об использовании повреждённого устройства.

Окно содержит информацию об ошибке: [W] означает, что ошибка произошла в момент записи на диск, LUN - номер диска в виртуальном массиве RAID, номера секторов, при обращении к которым возникла ошибка, число попыток обращения, номер и описание ошибки (даваемое ОС в Windows). После нескольких повторных попыток, определённых параметрами, программа переходит в режим ожидания (если не выбран режим автоматического пропуска ошибок), и кнопка Повторить становится активной. Сообщение выводится перед тем, как блок данных будет обработан.

Прервать: прервать текущую операцию.

При нажатии на кнопку Прервать секторы с ошибками не будут скопированы в место для записи (это поведение может быть изменено в следующих версиях). Кнопка может быть неактивной, если операция не может быть прервана в данный момент.

Повторить: повторить попытку доступа.

В некоторых случаях возможно успешное считывание информации с диска после нескольких дополнительных попыток. В этом случае выполнение операции продолжается без искажения информации.

Игнорировать: продолжить операцию, проигнорировав ошибку.

Текущая операция будет продолжена, но часть информации будет искажена. Если ошибка возникает при чтении структуры файловой системы, то могут быть потеряны некоторые файлы, нарушена структура директорий.

Игнорир. все: продолжать операцию, пропуская все аналогичные ошибки.

После нескольких повторных попыток, определённых параметрами, программа не переходит в режим ожилания, ошибка игнорируется, продолжается выполнение текущей операции.

Обновить: заново открыть дескриптор диска (Windows, Linux). Используйте соответствующий дополнительный параметр для автоматического повторного открытия после каждой ошибки.

ATA Reset: выполнить программный сброс ATA soft reset. Доступно только, если диск открыт через ATA interface в DOS.

Параметры: параметры доступа к диску

Подтвердить, Отмена: используются для переменной %CONFIRM% в Скрипте обработки ввода-вывода


DMDE - Скрипт обработки ввода-вывода

Содержание · Меню · Диск

Скрипт обработки ввода-вывода

Параметры ввода-вывода Диалог ввода-вывода

Скрипт может использоваться для журналирования ошибок ввода-вывода, а также для расширенной обработки ошибок (включая вызовы внешних программ). Функция доступна только в Professional Edition.

Скрипт можно загрузить или изменить через окно Параметров ввода-вывода (кнопка Скрипт).

Файл ondevhsc.txt содержит краткое описание доступных команд и некоторые примеры.

Допустимые строки команд имеют вид:
IF УСЛОВИЕ КОМАНДА
или
КОМАНДА
или
:МЕТКА

где УСЛОВИЕ задаётся равенством или неравенством (!=, >, <, >=, <=, =) двух величин,
величинам могут быть целые числа (0, 1, ...) или переменные (список ниже) или простые математические выражения (операторы +, -, *, %, /, без скобок, математический порядок операций игнорируется), например, %ERROR%=0

Комментарии предваряются двумя минусами (--)

Переменные

Целые, включая ноль

%CONFIRM% | =1, если нажата кнопка Подтвердить, =0, если Отменить (выводится окно диалога и ожидается выбор пользователя)
%DISKNUM% | номер диска в RAID-массиве
%TRYNUM% | номер попытки ввода-вывода
%LBA% | первый сектор в операции ввода-вывода
%SECNUM% | число секторов
%ERROR% | номер ошибки
%ATASTATUS% | значение регистра ATA Status (если снят бит BSY, только DOS ATA)
%ATAERROR% | значение регистра ATA Error (если установлен бит ERR в %ATASTATUS%)
%LINE% | текущий номер строки в скрипте
%SERVICE% | тип ввода-вывода: 0-ATA 1-ATAPI 3-BIOSINT13OLD 4-BIOSINT13 5-DOSINT25 6-DOSINT73 7-DOSASPI 8-DOSMSCDEX 9-DOSFILE 11-WINFILE 12-WINSCSI 13-WIN9XINT13 14-WINATA 20-LINUXFILE 21-LINUXSCSI
%LASTRES% | результат предыдущей команды
%LASTERR% | ошибка предыдущей команды

Команды

SHOWDLG -- принудительно показать окно диалога ввода-вывода
WAIT -- ожидать выбор пользователя
DELAY N -- ожидать N мсек.
EXECCMD CMDLINE -- выполнить внешнюю команду CMDLINE используя командый процессор
(эквивалентно "cmd CMDLINE" в Windows)
EXECCMDQ CMDLINE -- выполнить без создания нового консольного окна
EXEC "FILENAME" CMDLINE -- вызвать внешнюю программу FILENAME с параметрамии CMDLINE
EXECQ "FILENAME" CMDLINE -- вызвать без создания нового консольного окна
MSDOS -- вызвать командный процессор (OS Windows, DOS)
GOTO LABELNAME -- перейти к метке LABELNAME в скрипте (к строке :LABELNAME)
RETURN -- прервать выполнение скрипта, обработать ошибку согласно параметрам ввода-вывода
RETRETRY -- прервать выполнение скрипта как при нажатии на кнопку Retry
RETIGNORE -- прервать выполнение скрипта как при нажатии на кнопку Ignore
RETABORT -- прервать выполнение скрипта как при нажатии на кнопку Abort
ADDLOG "FILENAME" LOGLINE -- записать строку LOGLINE в файл FILENAME
(строка LOGLINE может содержать переменные)
CANCELIO -- вызов CancelIO (только WinNT+)
(доступно, если устройство открыто с опцией overlapped)
OVLRESLT N -- ожидать результат Overlapped-операции (N=1: ожидать; N=0: не ожидать) (только WinNT+)
(должно использоваться, если устройство открыто с опцией overlapped)
RESETHANDLE -- заново открыть устройство (только WinNT+)
ATARESET -- выполнить сброс ATA Soft Reset (только DOS ATA)
ATARESETDET -- выполнить сброс ATA Soft reset и ATA Identify (только DOS ATA)

Спецификаторы формата

Для форматирования числа после имени переменной через двоеточие может быть добавлен специфиактор by, например,
%LBA:8x% -- ширина: 8, шестнадцатеричный вывод

Пример

IF %ERROR%=0 RETURN -- выйти, если нет ошибки
IF %ERROR%=128 GOTO LABEL1
IF %ERROR%=5 GOTO LABEL1
RETURN

:LABEL1
IF %CONFIRM%=0 RETRETRY -- повтор, если нажата кнопка Отмена
-- продолжить выполнение скрипта, если нажата кнопка Подтвердить
EXECCMD /K ECHO error %ERROR% at LBA: %LBA% (%SECNUM%) try: %TRYNUM%. Type EXIT to return.
IF %TRYNUM%<2 RETRETRY
DELAY 500
ADDLOG "C:\ERRORS.LOG" error %ERROR:x% at LBA: %LBA:10% (%SECNUM%) try: %TRYNUM%
RETIGNORE


DMDE - Копировать секторы

Содержание · Работа · Меню · Сервис

Копировать секторы

Работа с повреждёнными дисками Открытие образов дисков

Инструмент для создания и заливки образов дисков, клонирования дисков, создания дампов.

Если в качестве места для записи указан файл, будет создан файл-образ.

Если вместо этого в качестве места для записи указан диск/раздел, то запись выполняется непосредственно на диск, все данные на целевом диске будут перезаписаны, а файловая система будет стерта.

Если производится запись на диск, содержащий потерянные данные (например, применяется патч), это может привести к дальнейшей потере данных.

Источник и место для записи

Диск | Выбор диска, тома, образа, массива RAID в качестве источника/места для записи
Раздел | Выбор раздела в качестве источника/места для записи (Диск - для смены устройства). Чтобы целиком выбрать текущий диск или массив, следует указать верхний пункт в списке разделов
Файл | Использовать файл в качестве источника/места для записи
Редактор | Использовать объект, открытый в Дисковом редакторе, в качестве источника
Выделение | Использовать выделенный в дисковом редакторе блок в качестве источника

Поля ввода Начальный сектор/байт, Конечный сектор/байт, Число секторов/Размер в байтах заполняются автоматически при выборе источника/приемника с помощью кнопки. Если в качестве источника выбран Файл или Редактор, то значения полей указываются в байтах.

Можно вручную задать диапазон для копирования внутри источника и начальное смещение для приемника. Начальный сектор источника копируется в Начальный сектор приёмника независимо от направления копирования. При выборе раздела начальный сектор задаёт смещение относительно начала раздела (не устройства).

Кнопка Разделить позволяет разделить файл назначения на части. При этом также создается файл конфигурации RAID raidinfo.ini для последующего открытия раздробленного образа или для продолжения записи образа (открыть или указать с помощью опции Диск - Образы дисков / Логи).

С помощью кнопки Диск в качестве источника или приёмника также можно выбрать файл (образ диска). В этом случае можно указать параметры копирования, доступные только для диска.

Если в качестве источника используется Редактор или Выделение, некоторые логические ошибки (такие как недопустимые номера кластеров или секторов) игнорируются без вывода сообщений.

Параметры

Лог-файл содержит отчёт о скопированных секторах и ошибках при копировании. Если в качестве источника выбран Раздел, номера секторов в логе указываются относительно начала диска (а не раздела).

Опция "использовать лог для продолжения" позволяет пропустить уже скопированные секторы (опция доступна только в Professional Edition). В частности, если настройки копирования и параметры не изменены, то при новом запуске копирование будет продолжено с последней позиции. Также возможно копирование в несколько проходов с уменьшением перескока на бэдах, предварительное копирование важных областей, копирование в разных направлениях.

Если изменить параметры ввода-вывода (уменьшить прыжок через секторы, увеличить число автоповторов с 0 или уменьшить размер буфера ввода-вывода при 0 повторов), то при новом запуске начнётся копирование секторов, пропущенных раннее из-за перескока на бэдах.

Опция "Повторить копирование плохих секторов лога" (доступно только в Professional Edition) - для повторного копирования сбойных секторов, когда скопированы все пропущенные секторы. При каждом запуске копирование сбойных секторов начинается сначала, продолжение невозможно.

Сбросить лог, когда скопировано число секторов: принудительный сброс отчёта на диск (обновление лог-файла) каждый раз после копирования указанного числа секторов.

Кнопка "Параметры" позволяет настроить параметры ввода-вывода для обработки ошибок (повторы, перескоки на бэдах и др.)

Обратный ход: копирование в направлении от конца к началу. Используется для создания образа при проблемах с диском.

В два потока: выполнение чтения и записи в параллельных потоках для увеличения скорости. Не следует использовать опцию для копирования дисков с ошибками.

Поле ввода Продолжить с сектора/байта определяет позицию, начиная с которой будет продолжено копирование. Позиция указывается относительно начала источника. В случае обратного хода копирование начнётся перед указанной позицией и продолжится в направлении к началу (например, если установлено значение 10, то скопируется сектор 9 и далее к началу).

Опция Заблокировать источник при копировании блокирует тома источника, запрещает работу с файловой системой, чтобы предотвратить изменения во время копирования (только в Windows).

Меню

Сохранить/Загрузить: сохранить/загрузить настройки в файл/из файла.

Экспортировать лог в ddrescue mapfile: конвертировать лог-файл в формат файла ddrescue mapfile.

Экспорт плохих и пропущенных диапазонов из журнала: получить список плохих и нескопированных секторов. В дальнейшем список можно использовать для получения информации о поврежденных файлах, расположенных в плохих секторах (см. Восстановление данных).


DMDE - Массивы RAID

Содержание · Работа · Меню · Диск

Массивы RAID

Диалог "Собрать RAID"

Меню - Диск - Выбрать диск - пункт "Собрать RAID"

Инструмент для сборки виртуальных массивов RAID из одиночных дисков (или разделов и образов) в случаях, когда RAID не может быть собран средствами контроллера (аппаратный RAID) или операционной системы (программный RAID), а также для автоматического определения конфигурации в случае, если некоторые параметры массива неизвестны.

При необходимости диски должны быть отсоединены от RAID-контроллера и подключены к компьютеру как одиночные диски.

Неправильный выбор типа массива, чередования или порядка дисков приводит к некорректному восстановлению данных (даже если структура директорий реконструируется правильно).

Опция RAID: авторасчет (сканирование) позволяет вычислять неизвестные параметры и / или порядок дисков для массивов с чередованием. Некоторые диски могут отсутствовать (однако, исходное количество дисков должно быть указано точно). В процессе сканирования статистически рассчитываются наиболее вероятные конфигурации RAID. Чем более точно указаны возможные параметры RAID, тем быстрее и точнее результаты. Например, программная реализация RAID-5 в ОС Windows использует чередование backward dynamic и размер страйпа 64 КиБ, таким образом данные параметры можно задать до сканирования.

В большинстве программных реализаций RAID используются контейнеры, шаг смещения (LBA) используется для проверки различных смещений контейнера. Современные ОС используют выравнивание 1MiB, поэтому по умолчанию используется шаг 2048 LBA (1MiB). Старые ОС могут использовать выравнивание по 63 LBA. Для полностью неизвестного смещения можно указать шаг 1 LBA.

Типы массивов

RAID-0. Массив обычно содержит два диска, информация на которых записывается поочерёдно блоками (stripe) указанного размера. Без одного из дисков могут быть восстановить только небольшие файлы, полностью уместившиеся в одном блоке.

RAID-1. Массив обычно содержит два диска, данные дублируются. Размер блока не используется. Поддерживается только чтение. Один полностью здоровый диск может быть открыт как одиночное устройство без потери данных.

RAID-4. Массив обычно содержит три диска. Один из дисков содержит данные контроля чётности. Данные поочерёдно записываются блоками на остальные диски. Без одного из дисков массива данные могут быть польностью восстановлены. Вместо отсутствующего диска следует использовать Пустой диск.

RAID-5. Массив обычно содержит три диска (или больше). Данные чередуются блоками между всеми дисками с одним блоком контроля чётности на остальные блоки данных. По способу чередования данных массивы RAID-5 делятся на четыре основных вида. На некоторых массивах (обычно аппаратных) блоки чётности могут чередоваться реже блоков данных (delayed parity). Данные могут быть полностью восстановлены без одного из дисков (который следует заменить на Пустой диск).

RAID-6. Массив обычно содержит четыре диска (или больше). Подобен массиву RAID-5, но для контроля чётности используются два блока (разных типов). В программе поддерживает только один тип контроля чётности, поэтому только один диск может быть заменён Пустым диском. Поддерживается только чтение.

RAID: Custom rotation. Можно задать произвольное чередование данных (Mеню - Чередование...). Целые числа от 0 определяют блоки данных согласно их порядку на дисках, -1 определяет блок чётности XOR, -2 определяет неиспользуемый блок.

Например, для диаграммы: |  |  |  | => | чередование указывается матрицей:
Диск#0 | Диск#1 | Диск#2 | Диск#3 |  |
A1 | A2 | Ap | Aq |  | 0 1 -1 -2
B1 | Bp | Bq | B2 |  | 2 -1 -2 3
Cp | Cq | C1 | C2 |  | -1 -2 4 5
Dq | D1 | D2 | Dp |  | -2 6 7 -1

JBOD/Spanned. Набор из нескольких дисков, используемых последовательно. Данные не чередуются, размер блока не используется. Данные, расположенные на любом из дисков, будут потеряны, если диск отсутствует. Поддерживается чтение и запись.

Параметры массивов

Размер блока: размер блока при чередовании данных. Не используется в RAID-1, JBOD.
Delay: задержка [чередования], используется только в RAID-5/6 с "delayed parity".
Смещение: смещение начала данных на диске (обычно используется в программных массивах RAID).
Смещение и размер: смещение и размер элемента массива на отдельном диске.
Пустой диск (NULL): используeтся вместо отсутствующего или повреждённого диска.
Чередование...: ручное задание чередования блоков данных (Custom rotation).
Сохранить/Загрузить: созранить/загрузить конфигурацию массива RAID
Упреждающее чтение: повысить производительность на массиве с маленьким размером страйпа (не рекомендуется на дисках с плохими секторами).


DMDE - Панель файлов

Содержание · Работа с программой

Панель файлов

Файловая панель отображает виртуальную структуру директорий и позволяет просматривать директории и выбирать объекты для восстановления, а также открывать их в Дисковом редакторе. Для доступа к панели файлов необходимо открыть том.

Откройте виртуальную папку [Все найденные / виртуальная ФС], для виртуальной реконструкции файловой системы и отображения всех найденных и удалённых файлов и директорий. Результаты полного сканирования используются при реконструкции.

Для восстановления файлов, отмеченных как "найденные" или "удалённые" (см. описание иконок ниже), в окне диалога восстановления должны быть выбраны соответствующие опции.

Структура директорий является виртуальной и может отличаться о структуры непосредственно на диске или в обычном проводнике ОС. Виртуальные имена заключены в квадратные скобки или начинаются знаком $ и обычно размещены на самом верхнем уровне структуры директорий тома. Виртуальная папка $Root примерно соответствует корневой папке тома в обычном проводнике ОС.

[F2]/[Shift+F9]/[Shift+F10] или клик правой кнопкой на объекте вызывают контекстное меню.
[Enter] или двойной клик открывают директорию в панели, либо файл в редакторе или для предпросмотра.
[Ctrl+Enter] открывает объект в дисковом редакторе.
[Insert], [Пробел] отмечают объект для восстановления.

Атрибуты файлов

E/C/s: зашифрованный/сжатый/разреженный (NTFS)
D: директория
R/H/S/A: скрытый/только для чтения/системный/архивный
x/f: "удаленный"/"найденный"

Значки файлов

GUI | Con | Описание значка
dir | [.] | обычная директория, содержащая файлы
light dir | [ ] | директория, не содержащая файлы
dir brown dot | [x] | директория, содержащая удалённые файлы
dir cyan dot | [f] | директория, содержащая "найденные" файлы
dir cyan dot brown dot | [x} | директория, содержащая удалённые и "найденные" файлы
dir trash | (x) | удалённая директория
dir trash cyan dot | (f) | удалённая директория, содержащая "найденные" файлы
dir trash brackets | (.] | удалённая директория, содержащая неудаленные файлы (ошибка ФС)
cyan dir trash mark | (f] | удалённая директория, содержащая обычные и "найденные" файлы (ошибка ФС)
cyan dir | {f} | "найденная" директория (в квадратных скобках - номер блока ФС)
cyan dir yellow dot | {.} | "найденная" директория, содержащая обычные файлы
cyan dir brown dot | {x} | "найденная" директория, содержащая удалённые файлы
cyan dir yellow dot brown dot | {.) | "найденная" директория, содержащая обычные и удалённые файлы
cyan dir trash | (x} | "найденная" удалённая директория
cyan dir trash yellow dot | (r} | "найденная" удалённая директория, содержащая обычные файлы
cyan dir trash mark | (f} | "найденная" удалённая директория, содержащая неудаленные файлы
cyan dir trash mark | (.} | "найденная" удалённая директория, содержащая неудаленные и обычные файлы
204 green star | . | обычный файл (неудаленный файл в файловой системе)
file top left green bottom red | +. | [обычный] файл ФС, также найденный по сигнатурам
file top left green bottom red | -. | [обычный] файл ФС, не найденный по сигнатурам в соответствующем месте диска, возможно, поврежденный файл / неверный тип / нераспознанный
204 green star | f | "найденный" файл (в дополнительно найденных фрагментах ФС, номер фрагмента - в квадратных скобках, [J] означает журнал ФС)
204 green star | x | удалённый файл
204 green star | xf | удалённый "найденный" файл
file top left green | +. | файл, найденный по сигнатурам (Raw)
file top left bottom right green | +.+ | файл, найденный по сигнатурам, найдена сигнатура конца файла (EOF)
file top left green bottom right red | +.- | файл, найденный по сигнатурам, сигнатура конца не найдена
file top left green bottom red | +.~ | файл по сигнатурам, определён размер, вероятна фрагментация или частичная перезапись
file top left green bottom red | .+ | файл найден по сигнатуре конца
204 green star | [>] | директория, содержимое которой раскрыто не полностью
204 green star | |.| | виртуальная директория расширенных MFT-записей файла
blue folder | [.] | $MetaData - виртуальная директория, содержащая спец. файлы ФС
blue folder | [.] | $NonameFiles: содержит файлы, у которых потеряны имена и родители
cyan dir | {f} | $Raw: содержит файлы, найденные по сигнатурам
204 green star | . | ИмяФайла:ИмяПотока - альтернативный поток данных NTFS-файла (отображается после реконструкции ФС)


DMDE - Дисковый редактор

Содержание · Работа с программой

Дисковый редактор

Дисковый редактор позволяет просматривать и редактировать различные дисковые объекты, такие как секторы, файлы и другие структуры диска и файловой системы в шестнадчатеричном и форматном (структурированном) режимах, включая использование пользовательских шаблонов для разбора данных.

Ознакомьтесь с предупреждением по ссылке перед применением изменений.

Выбор объекта:
  • из меню Редактор - для выбора объекта диска или файловой системы или перехода к заданной позиции
  • из панели файлов - для выбора файла или директории (клик правой кнопкой - контекстное меню или клавиши [Ctrl+Enter])

Выбор режима просмотра (шаблона): меню Режим.

Переход в режим редактирования: меню Правка - Режим редактирования [Ctrl+E].
Редактирование файлов NTFS поддерживается только в RAW режиме.

Запись изменений на диск: меню Диск - Применить изменения [Ctrl+W].

Меню Сервис содержит дополнительные функции:
• Копировать секторы...: сохранить выделенный блок или весь объект в файл
• Заполнить секторы...: заполнить секторы шаблоном
• Найти строку: найти строку в выбранном объекте
• Найти спец. сектор: найти определённую структуру данных на диске

Жёлтый цвет текста в редакторе обозначает изменения, не записанные на диск.
Серый текст обозначает неиспользуемые данные (неиспользуемая часть кластера, не занятая запись, и т.д.).
Зелёный цвет данных обозначает ошибки ввода-вывода при чтении соответствующих секторов.
Красный текст обозначает логические ошибки в данных.


DMDE - Шаблоны редактора дисков

Содержание · Работа · Меню · Режим

Шаблоны редактора дисков

Дисковый редактор, кроме встроенных шаблонов, поддерживает пользовательские шаблоны для просмотра и редактирования различных дисковых структур. В шаблонах могут использоваться условия, операторы перехода, переменные для разбора сложных дисковых структур, таких как записи MFT.

По умолчанию шаблоны загружаются из файла template.txt. Для использования других файлов можно изменить параметр editortemplates= ini-файла, допускаются символы подстановки (например, editortemplates=template*).

Структура файла шаблонов

Каждый шаблон начинается с указания имени в квадратных скобках [Template Name], за которым следуют параметры и инструкции шаблона (по одной на строку файла).

Параметры шаблона

guid:{GUID} - идентификатор шаблона.
o:1 - шаблон может применяться к невыровненным по секторам сктруктурам (может применяться смещение).
fuse:0 - не использовать шаблон.
flow:0 - отображение по одной записи.
flow:1 - отображение записей одна за другой.
big-endian:1 - определяет порядок байт "big-endian".
h:Header - отображение постоянного заголовка Header.

Константы

Константы указываются в виде десятичных и шестнадцатеричных (с префиксом 0x) целых чисел.

Переменные

$RECSIZE - размер записи шаблона
$NEXTOFS - смещение, применяемое к блокам данных (см. далее)
$OFFSET - дополнительное относительное смещение, применяемое к блокам данных
$1 ... $4 - глобальные пользовательские переменные (64-битные целые со знаком)
$varname - локальная переменная (64-битное целое со знаком), где varname чувствительна к регистру и может содержать цифры, латинские буквы и символы подчеркивания. Локальная переменная должна быть инициализирована с помощью оператора присваивания := и действительна только внутри блока инструкций, в котором она инициализирована.

Блоки данных

Блок данных - это, обычно, отдельный байт/слово/двойное слово в указанной позиции, но также допустимы диапазоны байтов/бит, обрабатываемых как одна переменная. Блок данных заключается в фигурные скобки {...}.

{Z} определяет диапазон Z байт, начиная со смещения $NEXTOFS (при этом $NEXTOFS будет увеличен на Z байт);
{X,Z} определяет диапазон Z байт, начиная со смещения X,
{X:Y,Z} определяет диапазон Z бит, начиная со смещения X байт Y бит,
где X, Y и Z - любые переменные или константы;
несколько диапазонов разделяются точкой с запятой, например, {0x00,4;$1:$2,4}.

Форматы данных

Формат определяет способ отображения и редактирования блока данных (например, целое число / символ / строка).

Поддерживаются следующие форматы:
%u - беззнаковое целое (до 64 бит)
%d - целое со знаком (до 64 бит)
%X / %x - шестнадцатеричное число (до 64 бит)
%c - символ ANSI (8 бит)
C - строка ANSI
U - строка в Юникоде (UTF-16)
u - строка в кодировке utf-8
T - текстовая строка (в зависимости от таблицы кодировки)
UNIXDATE - дата в формате Unix (секунды с 1980)
FILETIME - дата в формате Windows file time (наносекунды с 1601)
F:ABCD.. - флаги (где A отображается, если выставлен бит 0, и B - если снят, и т.д.)

Вывод

Инструкция вывода определяет положение на экране и формат блока данных или переменной или просто выводит текст.

{...},x:X,w:W,c:C,f:Format выводит блок данных {...} в колонке X максимальной ширины W цветом С.
x:X,w:W,c:C,f:Text выводит Text в колонке X максимальной ширины W.
Параметры w:W и c:C опциональны (0 - цвет по умолчанию, 1 - заголовок, 8 - красный, 10 - серый).

Вывод производится в текущую строку, инструкция = (знак равенства) выполняет переход к следующей строке.

Операторы и выражения

Выражение - это комбинация переменных, констант, блоков данных и операторов (~, NOT; *, /, %; +, -; <<, >>; <, <=, >, >=; =, !=; &; ^; |; AND; OR), например:
$2+{0x08:$1,5}

Оператор присваивания := используется для копирования результата выражения в переменную, например:
$1:=$2+{0x08:$1,5}
$2:=$OFFSET & 8

Условия, циклы и переходы

Условия

IF Выражение1
... (инструкции для выполнения, если результат Выражения1 ненулевой/истина)
ELSEIF Выражение2
... (иначе инструкции для выполнения, если результат Выражения2 ненулевой/истина)
ELSE
... (иначе инструкции для выполнения в остальных случаях)
ENDIF

Циклы

WHILE Выражение3
... (инструкции для выполнения пока результат Выражение3 ненулевой/истина)
перейти к началу цикла:
CONTINUE
прервать выполнение цикла:
BREAK
ENDWHILE

Переходы

Строка LABEL:N определяет метку, а инструкция GOTO:N - переход на строку LABEL:N, где N - любая константа. Неаккуратное использование оператора перехода GOTO может привести к зацикливанию.

Переключатели и горячие ссылки

Инструкция переключателя $1:=TOGGLE:N,x:X выводит поле переключателя [+] ([-]) в столбце X текущей строки вывода, где N - уникальный номер переключателя (переменная или константа); и переменная $1 принимает значение 0 или 1 в зависимости от состояния переключателя (переключение происходит нажатием клавиши [пробел] или кликом мыши). Это позволяет изменять вывод шаблона на лету (например, разворачивать / сворачивать структуры, где номер переключателя N удобно устанавливать равным смещению структуры).

Инструкция горячей ссылки $VAR=Param делает текущую строку вывода горячей ссылкой, т.е. позволяет переходить к смещению объекта / записи / открывать другой связанный объект в окне редактора двойным щелчком по строке (или нажатием [Enter]). Param - это значение выражения, используемое ссылкой (смещение, номер записи, файла, сектора и т.д.), и $VAR - одна из следующих специальных переменных:
$GOTOREC, $GOTORECOFS - перейти к указанным номеру и смещению записи объекта
$GOTOOFS - перейти к указанному смещению объекта
$OPENLBA - открыть указанный сектор диска
$OPENVOLSEC - открыть указанный сектор тома
$OPENCLUSTER - открыть указанный кластер тома
$OPENVOLPAGE - открыть указанную страницу / объект тома
$OPENFILENUM - открыть файл с указанным номером
$OPENFILERECOFS - открыть файл по указанному смещению файловой записи в объекте
$OPENATTROFS - открыть поток данных по указанному смещению записи атрибута в объекте.
Можно указать шаблон, примененный после перехода, с помощью инструкции:
$OPENTEMPLATE='{GUID}'; указать дополнительное смещение шаблона: $OPENTEMPLOFS=Param.

Дополнительные разделы шаблона

Вычисление размера записи - инструкции между строками CALCSIZESTART и CALCSIZEEND. Используется, если размер записи может быть больше размера сектора и может зависеть от данных. Значение переменной $RECSIZE можно изменить только в этом разделе шаблона.

Предварительная обработка данных - инструкции между строками LOADSTART и LOADEND. Используется, например, для обработки USN в записях MFT (восстановление последних двух байт в каждом секторе). Блоки данных можно изменять в этом разделе шаблона: например, инструкция {X,Y}:={Z,Y} копирует Y байт по смещению Z в позицию по смещению X.

Постобработка данных - инструкции между строками FLUSHSTART и FLUSHEND. Используется для обратного преобразования перед записью изменённых данных на диск (также можно изменять блоки данных).


DMDE - Карта кластеров

Содержание · Работа · Меню · Сервис

Карта кластеров

Отчет карты кластеров

Карта кластеров показывает, какие кластеры тома используются и каким файлам они принадлежат. Команда меню Окна · Карта кластеров открывает / закрывает карту кластера, компактный режим карты кластеров переключает режимы просмотра отдельных кластеров и целых фрагментов файлов.

Для работы с картой кластеров необходимо открыть том и обновить карту кластеров (меню Сервис), указав требуемые параметры. Можно выбрать обработку только отмеченных файлов, обработку также структур FS и альтернативных потоков данных (поддержка зависит от файловой системы), выбрать Категории файлов.

Опция Использовать реконструкцию ФС требует предварительную реконструкцию ФС в памяти и предоставляет больше возможностей (поддержку найденных и удаленных файлов, полных путей к файлам, а также позволяет открывать соответствующие файлы в Панели файлов двойным щелчком по кластеру (или нажатием [Enter]) на карте кластеров). Если дополнительно нажата клавиша [Ctrl], то вместо этого файл открывается в дисковом редакторе. Можно переместить карту кластера в новую вкладку, чтобы закрепить ее и открывать файлы в отдельной панели.

Строка статуса карты содержит информацию о выделенном кластере / фрагменте файла:
[текущий кластер/число кластеров] "имя файла (потока)" vcn: номер кластера в файле

Для перехода между кластерами можно использовать команды меню:
Редактор · Кластер [Alt+C] - переход к кластеру тома
Редактор · Секторы тома [Alt+S] - переход к сектору тома
Редактор · Физические секторы [Alt+P] - переход к сектору устройства.

После этого команда меню
Редактор · Карта кластеров [Ctrl+M] открывает карту кластеров на заданной позиции,
Редактор · Данные файла [Ctrl+Alt+F] открывает файл, расположенный в данном месте диска.

Отчет карты кластеров

Отчет о карте кластера позволяет получить список файлов, расположенных в указанных секторах, а также получить список кластеров, занятых указанными файлами. Чтобы создать список кластеров, занятых указанными файлами, следует отметить необходимые файлы в дереве директорий, а затем использовать команду меню Инструменты · Обновить карту кластеров для перестроения карты с опцией только для отмеченные, а затем получить отчет.

Можно запросить отчет только о файлах, отчет в выводом путей к файлам и вывод границ фрагментов в байтах от начала диска для использования отчета в других программах.

Также можно получить информацию о размещении файлов без построения карты кластеров, используя опцию Список в диалоговом окне "Восстановить".


DMDE - Меню

Содержание · Работа с программой

Меню

  • Диск
    • Выбрать диск / задачу...
    • Открыть образ / лог-файл...
    • Собрать RAID...
    • Разделы диска...
    • Блокировка томов...
    • Параметры ввода-вывода...
    • Общий режим "только чтение"
    • Загрузить данные отката/дамп из файла...
    • Сохранить дамп изменений в файл...
    • Откатить изменения
    • Повторить изменения
    • Отменить все изменения
    • Применить изменения
  • Сервис
    • Полное сканирование...
    • Все найденные / виртуальная ФС...
    • Поиск в найденном (по имени)...
    • Восстановить / создать список файлов...
    • Восстановить EFS из бэкапа...
    • Обновить карту кластеров
    • Отчет карты кластеров...
    • Заново открыть параметры тома...
    • NTFS инструменты
    • Копировать секторы...
    • Заполнить секторы...
    • Найти...
  • Окна
  • Редактор
  • Режим
  • Правка


DMDE - Меню Диск

Содержание · Работа · Меню

Меню "Диск"

  • Выбрать диск / задачу...
  • Открыть образ / лог-файл......
  • Собрать RAID...
  • Разделы диска...
  • Блокировка томов...
  • Параметры ввода-вывода...
  • Общий режим "только чтение"
  • Загрузить данные отката/дамп из файла...
  • Сохранить дамп изменений в файл...
  • Откатить изменения
  • Повторить изменения
  • Отменить все изменения
  • Применить изменения


DMDE - Блокировка томов

Содержание · Работа · Меню · Диск

Блокировка томов

Блокировка используется в Windows NT+ при прямой записи на диски для предотвращения одновременного доступа с операционной системой.

DMDE блокирует тома автоматически при необходимости. Однако блокировка может быть запрещена, если том используется системой или другим приложением. В этом случае выдаётся запрос на повторную попытку блокировки или принудительное отключение тома. Закройте все приложения, которые могут использовать том, и повторите попытку.

Повтор | Повторить попытку блокировки тома
Принудительно | Отключить том. Внимание! Все используемые дескрипторы тома будут потеряны, в том числе несохраненные изменения в открытых файлах будут потеряны
Игнорировать | Попытаться произвести запись без блокировки тома. Внимание! Возможно повреждение файловой системы, или запись может быть запрещена операционной системой
Отмена | Отменить операцию

Внимание! Не следует блокировать или отключать том, с которого запущена программа DMDE. Нельзя заблокировать или отключить системный диск.

DMDE разблокирует тома при закрытии текущего устройства.

Дополнительное управление блокировкой вручную производится через меню Диск · Блокировка томов для записи.


DMDE - Управление изменениями

Содержание · Работа · Меню · Диск

Управление изменениями

Внимание! Прямое изменение содержимого диска может иметь дальнейшие последствия, включая потерю данных или невозможность запуска и работы системы.

При обнаружении новых ошибок ФС (а также при получении доступа к ФС со старыми ошибками) операционная система может запускать проверку диска для удаления ошибок, что может повлечь также удаление пользовательских данных. ОС может запускать проверку как в онлайн-режиме, так и во время загрузки.

Изменение разметки диска может привести также к невозможности загрузки с диска или к недоступности некоторых разделов. Никогда не изменяйте разметку на текущем загрузочном или системном диске. Запустите альтернативную систему с другого загрузочного диска или подключите диск в качестве дополнительного к другому компьютеру. Не запускайте программу с носителя, на который будут записываться изменения.

Чтобы прямые изменения содержимого диска вступили в силу в ОС, требуется перезагрузка, обновление конфигурации или переподключение съемного устройства. ОС Windows может запрещать прямую запись в некоторые занятые области диска - см. Блокировка томов. Некоторые антивирусы также могут блокировать прямую записаь на диск. В Windows можно попробовать опцию интерфейса IO SCSI, чтобы обойти некоторые ограничения.

Изменения с помощью команд Копировать секторы и Заполнить секторы записываются на диск немедленно.

Изменения в дисковом редакторе и менеджере разделов остаются виртуальными до момента их непосредственной записи на диск. Для управления виртуальными изменения можно использовать следующие команды меню Диск.

Общий режим "только чтение"

Запретить любые операции записи (для всех устройств и образов дисков).
См. также опцию Разрешить запись для отдельного устройства.

Загрузить данные отката/дамп из файла...

Загрузить данные отката (если они были сохранены перед применением последних изменений), и, таким образом, откатить последние изменения. Также можно загрузить виртуальные изменения, сохраненные в файл дампа вместо записи на диск.

Сохранить дамп изменений в файл...

Сохранить виртуальные изменения в файл вместо непосредственной записи на диск. Позднее можно снова открыть диск и загрузить все непримененные изменения.

Откатить изменения

Групповая отмена последних изменений. Для отмены отдельных действий следует использовать соответствующие команды дискового редактора (меню Правка) или менеджера разделов

Повторить изменения

Групповое повторение последних отменённых изменений.

Отменить все изменения

Отмена всех непримененных изменений.

Применить изменения [Ctrl+W]

Записать изменения на диск.


DMDE - Меню Сервис

Содержание · Работа · Меню

Меню "Сервис"

  • Полное сканирование...
  • Все найденные / виртуальная ФС...
  • Поиск в найденном (по имени)...
  • Восстановить / создать список файлов...
  • Восстановить EFS из бэкапа...
  • Обновить карту кластеров
  • Отчет карты кластеров...
  • Заново открыть параметры тома...
  • NTFS инструменты
  • Копировать секторы...
  • Заполнить секторы...
  • Найти...


DMDE - Виртуальная реконструкция файловой системы

Содержание · Работа · Меню · Сервис

Виртуальная реконструкция файловой системы

Виртуальная папка [Все найденные / виртуальная ФС] в панели файлов служит для виртуальной реконструкции структуры директорий и подготовки для восстановления найденных и удалённых данных. При необходимости можно уменьшить или увеличить количество результатов реконструкции, открыв папку повторно и изменив параметры.

При реконструкции используются результаты Полного сканирования (если оно было выполнено). Если файлы восстанавливаются некорректно, следует попробовать восстановление из других найденных томов - вернуться к результатам полного сканирования или к окну Разделы и открыть следующий том.

FAT/exFAT

Пересканировать текущую файловую систему

Полностью просканировать том, если требуются только результаты в рамках текущего формата ФС и полное сканирование не выполнено.

Реконструкция "по умолчанию"

Использовать результаты Полного сканирования.

Настройки использования таблиц FAT ("Параметры")

Таблицы FAT содержат цепочки кластеров для сборки фрагментированных файлов и директорий. После тестирования программа выбирает вариант использования таблиц. Однако, можно попробовать разные параметры для улучшения реконструкции и результатов восстановления данных в целом или отдельных файлов.

Можно выбрать, какая из таблиц будет использоваться (FAT1 или FAT2), или полностью отключить использование таблиц (не использовать FAT-таблицы). Опция проверять блоки (не использовать плохие секторы) может позволить исключить неправильные цепочки, если таблицы повереждены частично. ExFAT имеет только одну таблицу FAT, при этом она не тестируется (значения в таблице корректны только для цепочек фрагментированных файлов).

Остальные ФС (кроме FAT)

"Чистая" реконструкция ФС

Выбор результатов только внутри исходной ФС. Наиболее точная реконструкция при незначительных повреждениях ФС.

Реконструкция "по умолчанию", меньше (--) или больше (++) результатов

Использование результатов Полного сканирования. Можно уменьшить/увеличить число результатов реконструкции кнопками -- и ++. Цветовой индикатор условно показывает качество и количество выбранных результатов (чем больше дополнительных результатов, тем хуже их качество).

Дополнительные параметры

Дополнительные параметры предназначены, в основном, для специалистов для улучшения реконструкции файловой системы при её значительных повреждениях.

Номера MFT (NTFS)

Фильтрация файлов по номерам MFT для частичной реконструкции (в случае если полная реконструкция невозможна из-за недостатка памяти).

предотвратить неверные слияния

Предотвратить возможное неправильное слияние ветвей каталогов (учитывать метки времени).

обработать INDX'ы (NTFS)

Улучшенная (более медленная) реконструкция структуры каталогов с использованием информации из INDX'ов поверх отсутствующей информации из MFT (макс. - принудительная обработка INDX'ов).

Cмещенные (NTFS)

Учёт смещённых записей MFT (необходимо Полное сканирование).

Найденные дополнительно (NTFS)

Включение дополнительно найденных файлов (возможно наличие мусора, однако, могут найтись некоторые потерянные файлы).

Тех. записи

Включение в результаты специальных записей для анализа.

MFT/Фрагменты ФС

Вручную выбрать фрагменты ФС для использования в реконструкции. Фрагменты сгруппированы по релевантности открытому тому (вычисляется статистически):
Наилучшие, Корректные - наиболее релевантные и релевантные
Связанные - релевантные другим вариантам открытого тома (см. Полное сканирование),
Неизвестные - релевантные тома не удалось определить,
Сторонние - релевантные другим томам,
Мелкие (найденные дополнительно) - слишком мелкие для получения статистики,
Недопустимые - несовместимые с открытым томом по параметрам ФС.

ReFS

В ReFS v3 любой узел директории содержит идентификатор тома. Другие узлы в списке фрагментов FS - это узлы с идентификатором тома, отличающимся от ид. открытого тома.

В корректной ФС верхние узлы содержат ссылки на все остальные узлы (промежуточные и конечные). При любом изменении ReFS записывает новые версии узлов в новом расположении и обновляет ссылки, так что на диске может быть множество старых узлов директорий без ссылок. Однако в поврежденной FS среди них могут быть также потерянные узлы. Поэтому по умолчанию старые узлы также обрабатываются и используется контроль версий файлов для исключения старых ссылок на файлы (если не используется опция включить все записи старых файлов).


DMDE - Команды тома

Содержание · Работа · Меню · Сервис

Команды для работы с открытым томом

Поиск в найденном (по имени)

Поиск файлов и директорий в соответствии с шаблоном. См. опции категории файлов и фильтры в разделе Восстановление данных. Поиск ведётся среди уже найденных файлов тома. Для поиска также среди удалённых и других найденных файлов требуется предварительная реконструкция файловой системы.

Вы можете переместить панель поиска в новую вкладку, чтобы закрепить ее и открывать каталоги в отдельной панели.

Обновить карту кластеров

Обновление информации о расположении файлов на томе.

Заново открыть параметры тома...

Просмотр параметров и повторное открытие тома без результатов Полного сканирования и реконструкции.


DMDE - NTFS инструменты

Содержание · Работа · Меню · Сервис

NTFS инструменты

Предупреждение

Предупреждение! В случае несовместимой версии тома NTFS выполнение этих команд может привести к повреждению файловой системы. Если файлы или папки тома отображаются программой неправильно, или не уверены - не используйте инструменты NTFS.
Выполнение команд на диске, на котором расположены файлы загруженной операционной системы, приводит к потере данных и повреждению ОС.
При записи на диск выполняется блокировка тома. После выполнения команд следует проверить диск, используя системную программу chkdsk.
Не рекомендуется создавать файлы с русскоязычными именами, а также использовать в именах какие-либо специальные символы.

Перед выполнением команд необходимо открыть том NTFS, открыть нужную папку в панели файлов.

Копировать файл

Копировать, перезаписать или дописать файл в открытый том NTFS, не используя системный драйвер NTFS.

Откройте в файловой панели директорию, в которую следует скопировать файл.
Вызовите команду меню.
Выберите исходный файл.
Введите имя файла для записи.
Если файл для записи существует, укажите, следует ли его перезаписать или добавить новый файл в конец старого.

Для записи наобходимое наличие в открытом томе непрерывного свободного места достаточного объёма.

Создать директорию

Создать директорию на открытом томе NTFS, не используя системный драйвер NTFS.

Директория создаётся в текущей папке панели файлов.

Удалить файл/пустую папку

Удалить выделенный файл или пустую папку открытом томе NTFS, не используя системный драйвер NTFS.

Исправить INDX-списки NTFS директории...

Исправить все INDX-записи для директории, открытой в панели файлов.


DMDE - Заполнить секторы

Содержание · Работа · Меню · Сервис

Заполнить секторы

Запись шестандцатеричного шаблона или шаблона из файла в секторы диска. Шаблон записывается многократно, покрывая все указанные секторы.

Ознакомьтесь с предупреждением по ссылке перед изменением содержимого диска. Все данные будут перезаписаны, запись производится непосредственно на диск, отмена невозможна.

Максимальный размер hex-шаблона - 8 байт. Для использования шаблонов большего размера необходимо использовать файл.

Выравнивание по секторам: если опция выбрана и очередная копия шаблона не умещается целиком в текущий сектор, то остаток сектора заполняется нулями, а следующая копия шаблона записывается в начало нового сектора. Иначе копии шаблона записываются подряд без учёта границ секторов.


DMDE - Найти спец. сектор

Содержание · Работа · Меню · Сервис

Найти спец. сектор

Поиск структур диска и файловых систем. Поиск ведётся по всему физическому диску, начиная со следующего за текущим сектора диска.

Найти строку

Поиск строки в открытом объекте дискового редактора.

Настройки для поиска повторяющегося шаблона

X раз подряд: поиск шаблона, повторяющегося подряд указанное число раз
Перейти к концу повторений: если шаблон начинает повторяться подряд, перейти сразу к концу повторений (вместо поиска каждого повторения)

Данные настройки, например, могут использоваться для поиска начала и конца массивов нулей или других значений.

Искать далее

Продолжить поиск строки в текущем объекте или спец. сектора по всему диску, начиная с текущей позиции в дисковом редакторе.


DMDE - Меню Окна

Содержание · Работа · Меню

Меню "Окна"

  • Дерево папок
  • Панель файлов
  • Редактор
  • Карта кластеров
  • Предпросмотр
  • Панель поиска (Поиск в найденном)
  • В новую вкладку

Открыть/закрыть/перейти к окну программы.
Переключение между окнами возможно также с помощью клавиш [Ctrl+Tab].

Предпросмотр

При включенной опции Панель файлов по умолчанию открывает графические файлы в режиме просмотра изображений.

В новую вкладку

Открыть текущую панель в новой вкладке интерфейса. Если это панель поиска или карта кластеров, то панель будет зафиксирована, и новые объекты будут открываться в отдельной панели.


DMDE - Меню Редактор

Содержание · Работа · Меню

Меню "Редактор"

Выбор объекта для просмотра/редактирования в Дисковом редакторе.

Таблица разделов | Открыть все секторы диска. Перейти к MBR (к начальному сектору диска).
Загрузочный сектор | Открыть все секторы тома. Перейти к boot-сектору тома.
Копия загрузочного сектора | Открыть все секторы тома. Перейти к копии boot-сектора.
Корневая директория | Открыть корневую директорию тома.
FAT/MFT | Для FAT - открыть FAT1 (основную таблицу кластеров), для NTFS - открыть MFT.
FAT Copy/MFT Mirror | Для FAT - открыть FAT2 (копию таблицы кластеров), для NTFS - открыть MFTMirr.
Файл MFT... | Открыть MFT. Перейти к укзанному файлу MFT.
Кластер... | Открыть все секторы тома. Перейти к указанному кластеру тома.
Сектор тома... | Открыть все секторы тома. перейти к указанному секору тома.
Физические секторы... | Открыть указанные секторы диска. Перейти к указанному сектору.
Данные файла | Открыть файл, расположенный в текущем кластере.
Директория | Открыть директорию, содержащую текущий файл. Перейти к файловой записи.
Кластер FAT/файл MFT | Для FAT - открыть FAT1; перейти в к кластеру FAT1, соответствующему текущему кластеру тома. Для NTFS - открыть MFT; перейти к записи MFT, соответствующей текущему файлу или кластеру тома.
Карта кластеров | Открыть Карту кластеров. Перейти к кластеру карты, соответстующему текущему кластеру тома.
Переход к позиции объекта... | Перейти к указнной позиции в открытом объекте.

Перед выполнением команд необходимо открыть том (кроме команд Таблица разделов, Физические секторы).


DMDE - Меню Режим

Содержание · Работа · Меню

Меню "Режим"

Выбор режима просмотра в дисковом редакторе.

Пользовательские шаблоны | Выбор шаблона
Шестнадцатеричный/текст | Для изменения кодовой таблицы используется команда Кодировка
Директория FAT | При нажатии [Enter] в окне редактора открывается файл или директория (если открыт том FAT)
FAT12/FAT16/FAT32 | Таблица кластеров FAT. Клавиша [Enter] - переход к соответствующему кластеру тома.
Таблица разделов MBR/GPT | Повторный вызов команды или нажатие [F6] - переключение MBR/GPT/GPT-копия. Клавиша [Enter] - переход к соответствующему сектору.
Загрузочный FAT/FAT32/NTFS | Boot-сектор. Повторный вызов команды или нажатие [F7] переключает файловую систему. [Enter] - открыть том.
Директория NTFS | INDX-запись директории NTFS. [Enter] - открыть файл или директориюв окне редактора (если открыт том NTFS).
Файл MFT | [Enter] - открыть выделенный атрибут или директорию в окне рекдактора. [Пробел] - просмотр подробностей атрибута.
RAW секторы NTFS-файла | Переключение между просмотром декодированных данных файла и просмотром RAW-данных сектора (содержащихся на диске).
Кодировка... | Выбор кодовой страницы для преобразования текста в режимах Шестнадцатеричный, Текст.


DMDE - Меню Правка

Содержание · Работа · Меню

Меню "Правка"

Команды для использования в дисковом редакторе.

Заполнить нулями | Заполнить нулями выделенный блок
Копировать | Копировать выделенный блок во внутренний буфер
Вставить | Вставить внутренний буфер в текущей позиции
Вставить файл... | Вставить файл в текущей позиции
Выделить блок | Переключение режима выделения. Также для выделения может использоваться [Shift] с клавишами-стрелками или мышь с нажатой левой кнопкой
Выделить всё | Выделить объект целиком
Экспорт в текстовый файл | Экспортировать вид текущей или выделенных записей в файл в текстовом формате
Перечитать блок | Прочитать данные с диска повторно
Скрыть/показать изменения | Переключение между отображением исходных данных и изменённых данных объекта
Откатить | Отменить последнюю правку (в режиме hex/текст - все изменения в пределах одного сектора)
Повторить | Повторить отменённую правку
Режим редактирования | Переключение режима редактирования


DMDE - Справка

Online: en pl ru

Справка DMDE · Содержание

  • О справке DMDE
  • О программе
    • Описание DMDE
    • Редакции DMDE
    • Описание файлов
    • Проблемы и ограничения
  • Установка и запуск *
    • Установка и запуск *
    • Системные требования
    • Активация
    • Настройки
    • Языки/Локализация
  • Работа с программой
    • Поиск и открытие тома
    • Восстановление данных
    • Управление разделами
    • Полное сканирование
    • Выбор диска
    • Параметры ввода-вывода
    • Образы и клоны дисков
    • Массивы RAID
    • Панель файлов
    • Дисковый редактор
    • Карта кластеров
  • Меню
    • Диск
    • Сервис
    • Окна
    • Редактор
    • Режим
    • Правка